summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am9
1 files changed, 2 insertions, 7 deletions
diff --git a/Makefile.am b/Makefile.am
index 15d59da7..60eb46e4 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -249,7 +249,7 @@ noinst_PROGRAMS += tools/supplicant-test \
tools/dbus-test tools/polkit-test \
tools/iptables-test tools/tap-test tools/wpad-test \
tools/stats-tool tools/private-network-test \
- unit/test-session unit/test-ippool unit/test-nat \
+ unit/test-session unit/test-ippool \
unit/test-iptables
tools_supplicant_test_SOURCES = $(gdbus_sources) tools/supplicant-test.c \
@@ -295,14 +295,9 @@ unit_test_ippool_LDADD = @GLIB_LIBS@ @DBUS_LIBS@ -ldl
unit_objects += $(unit_test_ippool_OBJECTS)
unit_test_iptables_SOURCES = $(gdbus_sources) src/log.c \
- src/iptables.c unit/test-iptables.c
+ src/iptables.c src/nat.c unit/test-iptables.c
unit_test_iptables_LDADD = @GLIB_LIBS@ @DBUS_LIBS@ @XTABLES_LIBS@ -ldl
unit_objects += $(unit_test_iptables_OBJECTS)
-
-unit_test_nat_SOURCES = $(gdbus_sources) src/log.c src/dbus.c \
- src/iptables.c src/nat.c unit/test-nat.c
-unit_test_nat_LDADD = @GLIB_LIBS@ @DBUS_LIBS@ @XTABLES_LIBS@ -ldl
-unit_objects += $(unit_nat_ippool_OBJECTS)
endif
test_scripts = test/get-state test/list-services \