summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am7
1 files changed, 7 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 3de71869..f5158ed8 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -32,6 +32,9 @@ gresolv_sources = gresolv/gresolv.h gresolv/gresolv.c
gweb_sources = gweb/gweb.h gweb/gweb.c
+gsupplicant_sources = gsupplicant/gsupplicant.h gsupplicant/dbus.h \
+ gsupplicant/supplicant.c gsupplicant/dbus.c
+
if DATAFILES
dbusdir = @DBUS_DATADIR@
@@ -72,6 +75,10 @@ else
src_connmand_SOURCES += src/udev-compat.c
endif
+if WIFI
+src_connmand_SOURCES += $(gsupplicant_sources)
+endif
+
src_connmand_LDADD = $(builtin_libadd) @GLIB_LIBS@ @DBUS_LIBS@ \
@CAPNG_LIBS@ @UDEV_LIBS@ -lresolv -ldl