summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorMarcel Holtmann <marcel@holtmann.org>2009-04-27 21:41:52 -0700
committerMarcel Holtmann <marcel@holtmann.org>2009-04-27 21:41:52 -0700
commite3fafb1cb55307f6c5f118872d72abdd03011cbd (patch)
tree910a28296e4769ae2e14f465b7123611bf10f788 /src/Makefile.am
parent5a5c569add1d4cc9eb8aaf8be40eac2bf8c97bd3 (diff)
downloadconnman-e3fafb1cb55307f6c5f118872d72abdd03011cbd.tar.gz
connman-e3fafb1cb55307f6c5f118872d72abdd03011cbd.tar.bz2
connman-e3fafb1cb55307f6c5f118872d72abdd03011cbd.zip
Add infrastructure for built-in plugins
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am5
1 files changed, 3 insertions, 2 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 9051c7f0..9a1738c4 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -23,7 +23,8 @@ rules_DATA = 92-connman.rules
endif
endif
-connmand_LDADD = @GDBUS_LIBS@ @GLIB_LIBS@ @GTHREAD_LIBS@ @UDEV_LIBS@ -ldl
+connmand_LDADD = $(top_builddir)/plugins/libbuiltin.la \
+ @GDBUS_LIBS@ @GLIB_LIBS@ @GTHREAD_LIBS@ @UDEV_LIBS@ -ldl
connmand_LDFLAGS = -Wl,--export-dynamic -Wl,--version-script=connman.ver
@@ -46,7 +47,7 @@ AM_CFLAGS = @UDEV_CFLAGS@ @GTHREAD_CFLAGS@ @GLIB_CFLAGS@ @GDBUS_CFLAGS@ \
-DPLUGINDIR=\""$(plugindir)"\" \
-DSTORAGEDIR=\""$(storagedir)\""
-INCLUDES = -I$(top_builddir)/include
+INCLUDES = -I$(top_builddir)/include -I$(top_builddir)/plugins
EXTRA_DIST = connman-dbus.conf connman-polkit.conf connman.rules