summaryrefslogtreecommitdiff
path: root/plugins/Makefile.am
diff options
context:
space:
mode:
authorMarcel Holtmann <marcel@holtmann.org>2009-01-01 02:04:35 +0100
committerMarcel Holtmann <marcel@holtmann.org>2009-01-01 02:04:35 +0100
commit5be6dc3d4b22d736bb47e6fd6d4d5c8c11f70364 (patch)
tree0d51c1a68142f19b467db56ba65456bbece0ae87 /plugins/Makefile.am
parente77d5b6ca6caf487af324e7ebc1f2d7384c39ad4 (diff)
downloadconnman-5be6dc3d4b22d736bb47e6fd6d4d5c8c11f70364.tar.gz
connman-5be6dc3d4b22d736bb47e6fd6d4d5c8c11f70364.tar.bz2
connman-5be6dc3d4b22d736bb47e6fd6d4d5c8c11f70364.zip
Add skeleton for PPP plugin
Diffstat (limited to 'plugins/Makefile.am')
-rw-r--r--plugins/Makefile.am6
1 files changed, 6 insertions, 0 deletions
diff --git a/plugins/Makefile.am b/plugins/Makefile.am
index e663e14c..045c3f0b 100644
--- a/plugins/Makefile.am
+++ b/plugins/Makefile.am
@@ -27,6 +27,12 @@ dhclient_la_SOURCES = dhclient.c inet.h inet.c
dhclient_la_CFLAGS = @GLIB_CFLAGS@ @GDBUS_CFLAGS@ -DDHCLIENT=\"@DHCLIENT@\" \
-DSTATEDIR=\""$(statedir)"\" -DSCRIPTDIR=\""$(scriptdir)"\"
+if PPPD
+plugin_LTLIBRARIES += pppd.la
+
+pppd_la_SOURCES = pppd.c
+endif
+
ipv4_la_SOURCES = ipv4.c inet.h inet.c
dnsproxy_la_SOURCES = dnsproxy.c