summaryrefslogtreecommitdiff
path: root/plugins/Makefile.am
diff options
context:
space:
mode:
authorMarcel Holtmann <marcel@holtmann.org>2008-06-28 09:55:39 +0200
committerMarcel Holtmann <marcel@holtmann.org>2008-06-28 09:55:39 +0200
commit29e32b19209edcead937e85b0da62746c19ee625 (patch)
treee7609fa23f618196c59a3cf58638043f0cb373d1 /plugins/Makefile.am
parente7fcf53b8b53c0e69996d8881713694b8c48f016 (diff)
downloadconnman-29e32b19209edcead937e85b0da62746c19ee625.tar.gz
connman-29e32b19209edcead937e85b0da62746c19ee625.tar.bz2
connman-29e32b19209edcead937e85b0da62746c19ee625.zip
Don't use libconnman- prefix for plugins
Diffstat (limited to 'plugins/Makefile.am')
-rw-r--r--plugins/Makefile.am18
1 files changed, 8 insertions, 10 deletions
diff --git a/plugins/Makefile.am b/plugins/Makefile.am
index b34d79d7..90477393 100644
--- a/plugins/Makefile.am
+++ b/plugins/Makefile.am
@@ -1,22 +1,20 @@
plugindir = $(libdir)/connman/plugins
-plugin_LTLIBRARIES = libconnman-80203.la libconnman-80211.la \
- libconnman-bluetooth.la \
- libconnman-dhclient.la libconnman-resolvconf.la
+plugin_LTLIBRARIES = 80203.la 80211.la bluetooth.la \
+ dhclient.la resolvconf.la
-libconnman_80203_la_SOURCES = 80203.c
+80203_la_SOURCES = 80203.c
-libconnman_80211_la_SOURCES = 80211.c supplicant.h supplicant.c
+80211_la_SOURCES = 80211.c supplicant.h supplicant.c
-libconnman_bluetooth_la_SOURCES = bluetooth.c
+bluetooth_la_SOURCES = bluetooth.c
-libconnman_dhclient_la_SOURCES = dhclient.c
-libconnman_dhclient_la_LIBADD = @GDBUS_LIBS@
-libconnman_dhclient_la_CFLAGS = @GDBUS_CFLAGS@ -DDHCLIENT=\"@DHCLIENT@\" \
+dhclient_la_SOURCES = dhclient.c
+dhclient_la_CFLAGS = @GDBUS_CFLAGS@ -DDHCLIENT=\"@DHCLIENT@\" \
-DSTATEDIR=\""$(statedir)"\" -DSCRIPTDIR=\""$(scriptdir)"\"
-libconnman_resolvconf_la_SOURCES = resolvconf.c
+resolvconf_la_SOURCES = resolvconf.c
AM_LDFLAGS = -module -avoid-version -export-symbols-regex connman_plugin_desc