summaryrefslogtreecommitdiff
path: root/doc/Makefile.am
diff options
context:
space:
mode:
authorMarcel Holtmann <marcel@holtmann.org>2008-08-20 10:47:38 +0200
committerMarcel Holtmann <marcel@holtmann.org>2008-08-20 10:47:38 +0200
commit27d6492faf17da616776c141b7852079de51ea60 (patch)
tree96be7c0053447e344568365dbb8ab115404ffe48 /doc/Makefile.am
parent120501d82b2f136212668d9888b2732d330bbde9 (diff)
downloadconnman-27d6492faf17da616776c141b7852079de51ea60.tar.gz
connman-27d6492faf17da616776c141b7852079de51ea60.tar.bz2
connman-27d6492faf17da616776c141b7852079de51ea60.zip
Build D-Bus documentation in its own directory
Diffstat (limited to 'doc/Makefile.am')
-rw-r--r--doc/Makefile.am12
1 files changed, 7 insertions, 5 deletions
diff --git a/doc/Makefile.am b/doc/Makefile.am
index 0d0381f4..b9ade0fc 100644
--- a/doc/Makefile.am
+++ b/doc/Makefile.am
@@ -21,7 +21,7 @@ IGNORE_HFILES = connman connman.h rtnl.h dbus.h iface.h
HTML_IMAGES =
-content_files = connman-introduction.xml
+content_files = connman-introduction.xml dbus/manager.xml
INCLUDES = -I$(top_srcdir)/include -I$(top_srcdir)/gdbus \
$(GTHREAD_CFLAGS) $(GMODULE_CFLAGS) $(GLIB_CFLAGS) $(DBUS_CFLAGS)
@@ -34,15 +34,17 @@ MAINTAINERCLEANFILES = Makefile.in \
if ENABLE_GTK_DOC
include $(top_srcdir)/doc/gtk-doc.make
-all-local: xml/dbus-manager.xml
-
-xml/dbus-manager.xml : dbus-manager.xml dbus-introspection.xsl
+dbus/manager.xml: dbus-manager.xml dbus-introspection.xsl
+ $(MKDIR_P) -p $(builddir)/dbus
echo "<?xml version=\"1.0\"?>" > $@
echo "<!DOCTYPE refentry PUBLIC \"-//OASIS//DTD DocBook XML V4.1.2//EN\" \"http://www.oasis-open.org/docbook/xml/4.1.2/docbookx.dtd\">" >> $@
$(XSLTPROC) dbus-introspection.xsl $< | tail -n +2 >> $@
+clean-local:
+ rm -rf $(builddir)/dbus
+
else
-EXTRA_DIST = $(DOC_MAIN_SGML_FILE) $(content_files)
+EXTRA_DIST = $(DOC_MAIN_SGML_FILE) connman-introduction.xml
endif
EXTRA_DIST += dbus-introspection.dtd dbus-introspection.xsl \