summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorSamuel Ortiz <sameo@linux.intel.com>2010-10-28 01:14:37 +0200
committerSamuel Ortiz <sameo@linux.intel.com>2010-10-28 01:14:37 +0200
commit62e5b066e2816ab215f0ea0b6dfbcbd5dcbe3a7c (patch)
tree96c0ac2e1951dcba4e22dc8dac21dd20d658ecdb /configure.ac
parent29cbdb2c9ab82fce532004da6fe3574560efda0f (diff)
downloadconnman-62e5b066e2816ab215f0ea0b6dfbcbd5dcbe3a7c.tar.gz
connman-62e5b066e2816ab215f0ea0b6dfbcbd5dcbe3a7c.tar.bz2
connman-62e5b066e2816ab215f0ea0b6dfbcbd5dcbe3a7c.zip
iptables: Initial library commit
The ConnMan iptables library provides a simple internal API for adding netfilter chains and rules.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 6 insertions, 5 deletions
diff --git a/configure.ac b/configure.ac
index f45486ea..f36a7662 100644
--- a/configure.ac
+++ b/configure.ac
@@ -316,6 +316,12 @@ else
fi
AC_SUBST(DBUS_DATADIR)
+PKG_CHECK_MODULES(XTABLES, xtables, dummy=yes,
+ AC_MSG_ERROR(xtables library is required))
+AC_SUBST(XTABLES_CFLAGS)
+AC_SUBST(XTABLES_LIBS)
+
+
AC_ARG_ENABLE(systemd, AC_HELP_STRING([--enable-systemd],
[enable systemd support]), [enable_systemd=${enableval}])
if (test "${enable_systemd}" = "yes"); then
@@ -350,11 +356,6 @@ AM_CONDITIONAL(CLIENT, test "${enable_client}" = "yes")
AC_ARG_ENABLE(tools, AC_HELP_STRING([--enable-tools],
[enable testing tools]), [enable_tools=${enableval}])
if (test "${enable_tools}" = "yes"); then
- PKG_CHECK_MODULES(XTABLES, xtables, dummy=yes,
- AC_MSG_ERROR(xtables library is required))
- AC_SUBST(XTABLES_CFLAGS)
- AC_SUBST(XTABLES_LIBS)
-
PKG_CHECK_MODULES(NETLINK, libnl-1, dummy=yes,
AC_MSG_ERROR(Netlink library is required))
AC_SUBST(NETLINK_CFLAGS)