summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDaniel Wagner <daniel.wagner@bmw-carit.de>2012-11-02 17:26:19 +0100
committerDaniel Wagner <daniel.wagner@bmw-carit.de>2012-11-23 13:47:24 +0100
commitad50d442e320a4c36b1b6394e56c645402487ae8 (patch)
treecb3dddf4c63a178442e5989456741603e95dfb1c /configure.ac
parentef0ff73396e33e0195a8682d00f80c50421d91f1 (diff)
downloadconnman-ad50d442e320a4c36b1b6394e56c645402487ae8.tar.gz
connman-ad50d442e320a4c36b1b6394e56c645402487ae8.tar.bz2
connman-ad50d442e320a4c36b1b6394e56c645402487ae8.zip
session_policy_ivi: Add policy plugin for IVI
Add only the empty 'framework'. In the following patches we add step by step the implementation.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 6 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 48f365a2..70844ffc 100644
--- a/configure.ac
+++ b/configure.ac
@@ -258,6 +258,12 @@ AC_ARG_ENABLE(session-policy,
AM_CONDITIONAL(SESSION_POLICY, test "${enable_session_policy}" != "no")
AM_CONDITIONAL(SESSION_POLICY_BUILTIN, test "${enable_session_policy}" = "builtin")
+AC_ARG_ENABLE(session-policy-ivi,
+ AC_HELP_STRING([--enable-session-policy-ivi], [enable IVI Session policy configuration support]),
+ [enable_session_policy_ivi=${enableval}], [enable_session_policy_ivi="no"])
+AM_CONDITIONAL(SESSION_POLICY_IVI, test "${enable_session_policy_ivi}" != "no")
+AM_CONDITIONAL(SESSION_POLICY_IVI_BUILTIN, test "${enable_session_policy_ivi}" = "builtin")
+
AC_ARG_WITH(stats-max-file-size, AC_HELP_STRING([--with-stats-max-file-size=SIZE],
[Maximal size of a statistics round robin file]),
[stats_max_file_size=${withval}])