summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJaehyun Kim <jeik01.kim@samsung.com>2020-10-07 11:08:26 +0900
committerJaehyun Kim <jeik01.kim@samsung.com>2020-10-07 19:55:10 +0900
commit92632d79d49dd50e5a162b2cb78ca53a75d570e2 (patch)
treeb296be67afd3ef7242e95f494e41b718d5b69a36 /configure.ac
parent9395e7a086359069486e002c02b5777ca0c0df26 (diff)
downloadconnman-92632d79d49dd50e5a162b2cb78ca53a75d570e2.tar.gz
connman-92632d79d49dd50e5a162b2cb78ca53a75d570e2.tar.bz2
connman-92632d79d49dd50e5a162b2cb78ca53a75d570e2.zip
Add support for dlog
1. Add support for dlog 2. Add some log options to main.conf 3. Allow to simplify the amount of logs by option Change-Id: I8c1202ae267aca9bb2c18d44c2ccd3e6d5a74a73 Signed-off-by: Jaehyun Kim <jeik01.kim@samsung.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 5 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index bdece8d7..62ab2a36 100644
--- a/configure.ac
+++ b/configure.ac
@@ -308,6 +308,11 @@ PKG_CHECK_MODULES(DBUS, dbus-1 >= 1.4, dummy=yes,
AC_SUBST(DBUS_CFLAGS)
AC_SUBST(DBUS_LIBS)
+PKG_CHECK_MODULES(DLOG, dlog, dummy=yes,
+ AC_MSG_ERROR(dlog is required))
+AC_SUBST(DLOG_CFLAGS)
+AC_SUBST(DLOG_LIBS)
+
AC_ARG_WITH(dbusconfdir, AC_HELP_STRING([--with-dbusconfdir=PATH],
[path to D-Bus config directory]), [path_dbusconf=${withval}],
[path_dbusconf="`$PKG_CONFIG --variable=sysconfdir dbus-1`"])