summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorInaky Perez-Gonzalez <inaky@linux.intel.com>2009-10-08 11:33:14 +0900
committerMarcel Holtmann <marcel@holtmann.org>2009-10-10 14:35:49 +0200
commit9856478957f315b63cd273d8d76589bb38daf2de (patch)
treeb1e576d8fe051feb706840493c98fabbf5527d8d /configure.ac
parentb75ce22c33c824f61820091f06d4d9c0df7bcbed (diff)
downloadconnman-9856478957f315b63cd273d8d76589bb38daf2de.tar.gz
connman-9856478957f315b63cd273d8d76589bb38daf2de.tar.bz2
connman-9856478957f315b63cd273d8d76589bb38daf2de.zip
Add work around Intel WiMAX SDK API breakage
Release of the Intel WiMAX SDK 1.5 breaks source compatibility from 1.4 by removing WIMAX_API_DEVICE_STATUS_Connection_Idle. Rather than fight a useless fight, work aronud it with an autoconf test and a few (ugly) #ifdefs.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 9 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index aa61ba2a..25ada261 100644
--- a/configure.ac
+++ b/configure.ac
@@ -223,6 +223,15 @@ if (test "${enable_iwmx}" = "yes"); then
PKG_CONFIG_PATH=""
AC_SUBST(IWMXSDK_CFLAGS)
AC_SUBST(IWMXSDK_LIBS)
+ CPPFLAGS_save=$CPPFLAGS
+ CPPFLAGS="$IWMXSDK_CFLAGS $CPPFLAGS"
+ AH_TEMPLATE([HAVE_IWMXSDK_STATUS_IDLE],
+ [WIMAX_API_DEVICE_STATUS_Connection_Idle is present])
+ AC_CHECK_DECL(WIMAX_API_DEVICE_STATUS_Connection_Idle,
+ [AC_DEFINE([HAVE_IWMXSDK_STATUS_IDLE], [1], [])],
+ [],
+ [[#include <WiMaxType.h>]])
+ CPPFLAGS=$CPPFLAGS_save
fi
AM_CONDITIONAL(IWMX, test "${enable_iwmx}" = "yes")