summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorNishant Chaprana <n.chaprana@samsung.com>2019-05-22 22:18:39 +0530
committerNishant Chaprana <n.chaprana@samsung.com>2019-05-22 22:23:32 +0530
commit52770f14eb36bd8b4f587d67ae66a44a2d276921 (patch)
treeb8223f3da9af80bad71abc84b6d2d5cec5e10bc0 /configure.ac
parent5b0ef68d400aa263a42b8ca47ce6a7c38b588441 (diff)
downloadconnman-52770f14eb36bd8b4f587d67ae66a44a2d276921.tar.gz
connman-52770f14eb36bd8b4f587d67ae66a44a2d276921.tar.bz2
connman-52770f14eb36bd8b4f587d67ae66a44a2d276921.zip
Fixed build issue when built with --enable-tizen-ext-wifi-mesh optionsubmit/tizen/20190604.083831accepted/tizen/unified/20190605.215650
Below error comes when compiled with --enable-tizen-ext-wifi-mesh option:- [ 168s] src/mesh-netlink.c:29:31: fatal error: netlink/genl/genl.h: No such file or directory [ 168s] #include <netlink/genl/genl.h> [ 168s] ^ [ 168s] compilation terminated. [ 168s] Makefile:4430: recipe for target 'src/src_connmand-mesh-netlink.o' failed [ 168s] make[1]: *** [src/src_connmand-mesh-netlink.o] Error 1 [ 168s] make[1]: *** Waiting for unfinished jobs.... [ 168s] CC gweb/vpn_connman_vpnd-gionotls.o [ 169s] Makefile:1815: recipe for target 'all' failed [ 169s] make: *** [all] Error 2 Change-Id: Ib62a65cc0dbecca86a6ae9d67bfae880fcb30bbd Signed-off-by: Nishant Chaprana <n.chaprana@samsung.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 10 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index d1b76538..48ea09f6 100644
--- a/configure.ac
+++ b/configure.ac
@@ -270,6 +270,16 @@ PKG_CHECK_MODULES(GLIB, glib-2.0 >= 2.28, dummy=yes,
AC_SUBST(GLIB_CFLAGS)
AC_SUBST(GLIB_LIBS)
+PKG_CHECK_MODULES(LIBNL, libnl-3.0, dummy=yes,
+ AC_MSG_ERROR(libnl-3.0 is required))
+AC_SUBST(LIBNL_CFLAGS)
+AC_SUBST(LIBNL_LIBS)
+
+PKG_CHECK_MODULES(LIBNL_GENL, libnl-genl-3.0, dummy=yes,
+ AC_MSG_ERROR(libnl-genl-3.0 is required))
+AC_SUBST(LIBNL_GENL_CFLAGS)
+AC_SUBST(LIBNL_GENL_LIBS)
+
PKG_CHECK_MODULES(LIBSYSTEMD, libsystemd-daemon, dummy=yes,
AC_MSG_ERROR(libsystemd-daemon library is required))
AC_SUBST(LIBSYSTEMD_CFLAGS)