summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMarcel Holtmann <marcel@holtmann.org>2008-10-14 14:41:46 +0200
committerMarcel Holtmann <marcel@holtmann.org>2008-10-14 14:41:46 +0200
commit1eea67f44015142e6634e2b89593b0d587df864e (patch)
treeb9b87802ce45b5088d1dd024a0c05d1aaf1388b7 /configure.ac
parent4c171836e1a1001d4ba7f1364c50f3f44622d9c9 (diff)
downloadconnman-1eea67f44015142e6634e2b89593b0d587df864e.tar.gz
connman-1eea67f44015142e6634e2b89593b0d587df864e.tar.bz2
connman-1eea67f44015142e6634e2b89593b0d587df864e.zip
Add option to enable/disable HAL plugin
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 3 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 5857197a..1d438b17 100644
--- a/configure.ac
+++ b/configure.ac
@@ -74,7 +74,9 @@ AC_SUBST([GDBUS_LIBS], ['$(top_builddir)/gdbus/libgdbus.la $(DBUS_LIBS)'])
PKG_CHECK_MODULES(HAL, hal >= 0.5.8, hal_found=yes, hal_found=no)
AC_SUBST(HAL_CFLAGS)
AC_SUBST(HAL_LIBS)
-AM_CONDITIONAL(HAL, test "${hal_found}" = "yes")
+AC_ARG_ENABLE(hal, AC_HELP_STRING([--enable-hal],
+ [enable HAL plugin]), [enable_hal=${enableval}])
+AM_CONDITIONAL(HAL, test "${enable_hal}" = "yes" && test "${hal_found}" = "yes")
PKG_CHECK_MODULES(POLKIT, polkit-dbus >= 0.7, polkit_found=yes, polkit_found=no)
AC_SUBST(POLKIT_CFLAGS)