summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMarcel Holtmann <marcel@holtmann.org>2012-04-21 22:02:39 +0200
committerMarcel Holtmann <marcel@holtmann.org>2012-04-21 22:02:39 +0200
commitf68136601695afedc5802042517d8c33955e58fd (patch)
tree3a0a839072b75a530164eddf9832cdba75474c31 /configure.ac
parenta4ad2953a48dd276a3b16765cb4bb38b30d9a48d (diff)
downloadconnman-f68136601695afedc5802042517d8c33955e58fd.tar.gz
connman-f68136601695afedc5802042517d8c33955e58fd.tar.bz2
connman-f68136601695afedc5802042517d8c33955e58fd.zip
build: Build client and testing tools by default
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac32
1 files changed, 15 insertions, 17 deletions
diff --git a/configure.ac b/configure.ac
index 8ab72589..6f33c10b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -310,28 +310,16 @@ if (test -n "${path_systemdunit}"); then
fi
AM_CONDITIONAL(SYSTEMD, test -n "${path_systemdunit}")
+PKG_CHECK_MODULES(GNUTLS, gnutls, dummy=yes,
+ AC_MSG_ERROR(GnuTLS library is required))
+AC_SUBST(GNUTLS_CFLAGS)
+AC_SUBST(GNUTLS_LIBS)
+
PKG_CHECK_MODULES(XTABLES, xtables, dummy=yes,
AC_MSG_ERROR(Xtables library is required))
AC_SUBST(XTABLES_CFLAGS)
AC_SUBST(XTABLES_LIBS)
-AC_ARG_ENABLE(client, AC_HELP_STRING([--enable-client],
- [enable command line client]), [enable_client=${enableval}])
-AM_CONDITIONAL(CLIENT, test "${enable_client}" = "yes")
-
-AC_ARG_ENABLE(tools, AC_HELP_STRING([--enable-tools],
- [enable testing tools]), [enable_tools=${enableval}])
-if (test "${enable_tools}" = "yes"); then
- PKG_CHECK_MODULES(GNUTLS, gnutls, dummy=yes,
- AC_MSG_ERROR(GnuTLS library is required))
- AC_SUBST(GNUTLS_CFLAGS)
- AC_SUBST(GNUTLS_LIBS)
-
- AC_CHECK_HEADERS(linux/if_alg.h, dummy=yes,
- AC_MSG_ERROR(User-space algorithm header files are required))
-fi
-AM_CONDITIONAL(TOOLS, test "${enable_tools}" = "yes")
-
AC_ARG_ENABLE(test, AC_HELP_STRING([--enable-test],
[enable test/example scripts]), [enable_test=${enableval}])
AM_CONDITIONAL(TEST, test "${enable_test}" = "yes")
@@ -394,6 +382,16 @@ AC_ARG_ENABLE(pacrunner, AC_HELP_STRING([--disable-pacrunner],
[enable_pacrunner=${enableval}])
AM_CONDITIONAL(PACRUNNER, test "${enable_pacrunner}" != "no")
+AC_ARG_ENABLE(client, AC_HELP_STRING([--disable-client],
+ [disable command line client]),
+ [disable_client=${enableval}])
+AM_CONDITIONAL(CLIENT, test "${enable_client}" != "no")
+
+AC_ARG_ENABLE(tools, AC_HELP_STRING([--disable-tools],
+ [disable testing tools]),
+ [enable_tools=${enableval}])
+AM_CONDITIONAL(TOOLS, test "${enable_tools}" != "no")
+
if (test "${enable_loopback}" != "no"); then
AC_CHECK_HEADERS(sys/inotify.h, dummy=yes,
AC_MSG_ERROR(inotify header files are required))