summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMarcel Holtmann <marcel@holtmann.org>2010-09-09 18:44:06 +0200
committerMarcel Holtmann <marcel@holtmann.org>2010-09-09 18:44:06 +0200
commit3681fe237d4c9ed4b5a6f432c1002e25964207d8 (patch)
treecd665482db7d6c468a95af21b5c05272608843a9 /configure.ac
parent494e2a2858e53566ec2afd9e5ac0c092b4e665a4 (diff)
downloadconnman-3681fe237d4c9ed4b5a6f432c1002e25964207d8.tar.gz
connman-3681fe237d4c9ed4b5a6f432c1002e25964207d8.tar.bz2
connman-3681fe237d4c9ed4b5a6f432c1002e25964207d8.zip
Update support for PolicyKit with GDBus security integration
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 3 insertions, 6 deletions
diff --git a/configure.ac b/configure.ac
index 75abaf57..a02d6de3 100644
--- a/configure.ac
+++ b/configure.ac
@@ -293,13 +293,10 @@ AC_ARG_ENABLE(polkit,
AC_HELP_STRING([--enable-polkit], [enable PolicyKit support]),
[enable_polkit=${enableval}], [enable_polkit="no"])
if (test "${enable_polkit}" != "no"); then
- PKG_CHECK_MODULES(POLKIT, polkit-dbus >= 0.7, dummy=yes,
- AC_MSG_ERROR(PolicyKit >= 0.7 is required))
- AC_SUBST(POLKIT_CFLAGS)
- AC_SUBST(POLKIT_LIBS)
- POLKIT_DATADIR="`$PKG_CONFIG --variable=policydir polkit`"
+ POLKIT_DATADIR="`$PKG_CONFIG --variable=actiondir polkit`"
+ POLKIT_DATADIR=""
if (test -z "${POLKIT_DATADIR}"); then
- POLKIT_DATADIR="${datadir}/PolicyKit/policy"
+ POLKIT_DATADIR="${datadir}/polkit-1/actions"
fi
AC_SUBST(POLKIT_DATADIR)
fi