summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMarcel Holtmann <marcel@holtmann.org>2011-03-28 19:25:18 +0200
committerMarcel Holtmann <marcel@holtmann.org>2011-03-28 19:25:18 +0200
commit245461430b03aee3462b1375db686fd577443164 (patch)
tree41762e07bbca5abfdc4e7f9a59201620ae0af562 /configure.ac
parent8d1a0de849794f640ae78ff854b1d0a3b8a24e5c (diff)
downloadconnman-245461430b03aee3462b1375db686fd577443164.tar.gz
connman-245461430b03aee3462b1375db686fd577443164.tar.bz2
connman-245461430b03aee3462b1375db686fd577443164.zip
build: Check for dbus_connection_can_send_type function
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 7772e726..38351331 100644
--- a/configure.ac
+++ b/configure.ac
@@ -319,6 +319,10 @@ LIBS="$LIBS $DBUS_LIBS"
AC_CHECK_LIB(dbus-1, dbus_watch_get_unix_fd, dummy=yes,
AC_DEFINE(NEED_DBUS_WATCH_GET_UNIX_FD, 1,
[Define to 1 if you need the dbus_watch_get_unix_fd() function.]))
+AC_CHECK_LIB(dbus-1, dbus_connection_can_send_type, dummy=yes,
+ AC_DEFINE(NEED_DBUS_CONNECTION_CAN_SEND_TYPE, 1,
+ [Define to 1 if you need the dbus_connection_can_send_type() function.]
+))
CFLAGS="$saved_CFLAGS"
LIBS="$saved_LIBS"
AC_SUBST(DBUS_CFLAGS)