summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMarcel Holtmann <marcel@holtmann.org>2012-04-16 17:56:45 +0200
committerMarcel Holtmann <marcel@holtmann.org>2012-04-16 18:02:16 +0200
commitc9cdc86d132e2887be8f1ee05848acacc311f9ec (patch)
tree1e6000461b083d57758f6ac76d0af8f8964f4916 /configure.ac
parent49f34a018f0ecfd8b709632a0115d7babd9bf784 (diff)
downloadconnman-c9cdc86d132e2887be8f1ee05848acacc311f9ec.tar.gz
connman-c9cdc86d132e2887be8f1ee05848acacc311f9ec.tar.bz2
connman-c9cdc86d132e2887be8f1ee05848acacc311f9ec.zip
build: Require D-Bus 1.4 or later
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac17
1 files changed, 2 insertions, 15 deletions
diff --git a/configure.ac b/configure.ac
index 006533e3..6ad0b28c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -330,21 +330,8 @@ if (test "${enable_threads}" = "yes"); then
GLIB_LIBS="$GLIB_LIBS $GTHREAD_LIBS"
fi
-PKG_CHECK_MODULES(DBUS, dbus-1 >= 1.0, dummy=yes,
- AC_MSG_ERROR(D-Bus >= 1.0 is required))
-saved_CFLAGS="$CFLAGS"
-saved_LIBS="$LIBS"
-CFLAGS="$CFLAGS $DBUS_CFLAGS"
-LIBS="$LIBS $DBUS_LIBS"
-AC_CHECK_LIB(dbus-1, dbus_watch_get_unix_fd, dummy=yes,
- AC_DEFINE(NEED_DBUS_WATCH_GET_UNIX_FD, 1,
- [Define to 1 if you need the dbus_watch_get_unix_fd() function.]))
-AC_CHECK_LIB(dbus-1, dbus_connection_can_send_type, dummy=yes,
- AC_DEFINE(NEED_DBUS_CONNECTION_CAN_SEND_TYPE, 1,
- [Define to 1 if you need the dbus_connection_can_send_type() function.]
-))
-CFLAGS="$saved_CFLAGS"
-LIBS="$saved_LIBS"
+PKG_CHECK_MODULES(DBUS, dbus-1 >= 1.4, dummy=yes,
+ AC_MSG_ERROR(D-Bus >= 1.4 is required))
AC_SUBST(DBUS_CFLAGS)
AC_SUBST(DBUS_LIBS)