summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorSamuel Ortiz <sameo@linux.intel.com>2010-10-23 00:09:30 +0200
committerSamuel Ortiz <sameo@linux.intel.com>2010-10-23 00:09:30 +0200
commitf60ec47df7c4d4b0ee0f2557981e86fe74eb7423 (patch)
treed776efc6e17f6a9518681f0e81700ef6c26bd37d /configure.ac
parent8b49f33573921c27511cb60f7384a48ac3aaa7d4 (diff)
downloadconnman-f60ec47df7c4d4b0ee0f2557981e86fe74eb7423.tar.gz
connman-f60ec47df7c4d4b0ee0f2557981e86fe74eb7423.tar.bz2
connman-f60ec47df7c4d4b0ee0f2557981e86fe74eb7423.zip
iptables: Replace iptables-test program
The new iptables-test no longer links against the unstable libiptc library. A link against libxtables is still necessary as the iptables extensions are only registered against iptables through this library. Not using it would mean replicating any of the extensions ConnMan could potentially need.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 4 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index 1b52a930..f45486ea 100644
--- a/configure.ac
+++ b/configure.ac
@@ -350,10 +350,10 @@ AM_CONDITIONAL(CLIENT, test "${enable_client}" = "yes")
AC_ARG_ENABLE(tools, AC_HELP_STRING([--enable-tools],
[enable testing tools]), [enable_tools=${enableval}])
if (test "${enable_tools}" = "yes"); then
- PKG_CHECK_MODULES(IPTC, libiptc, dummy=yes,
- AC_MSG_ERROR(iptables library is required))
- AC_SUBST(IPTC_CFLAGS)
- AC_SUBST(IPTC_LIBS)
+ PKG_CHECK_MODULES(XTABLES, xtables, dummy=yes,
+ AC_MSG_ERROR(xtables library is required))
+ AC_SUBST(XTABLES_CFLAGS)
+ AC_SUBST(XTABLES_LIBS)
PKG_CHECK_MODULES(NETLINK, libnl-1, dummy=yes,
AC_MSG_ERROR(Netlink library is required))