summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMarcel Holtmann <marcel@holtmann.org>2009-04-28 00:11:52 -0700
committerMarcel Holtmann <marcel@holtmann.org>2009-04-28 00:11:52 -0700
commitd670a771cfe15aa99d812f4e4775f3924610a3af (patch)
tree154657fd924eb91ac2e0c6ecb68666728d05d612 /configure.ac
parent47bd0ee5afe38109771623335a5272f682432c5a (diff)
downloadconnman-d670a771cfe15aa99d812f4e4775f3924610a3af.tar.gz
connman-d670a771cfe15aa99d812f4e4775f3924610a3af.tar.bz2
connman-d670a771cfe15aa99d812f4e4775f3924610a3af.zip
Allow built-in of wifi, bluetooth and resolvconf plugins
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 6 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 2bcac75f..3b12175c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -62,11 +62,13 @@ if (test "${enable_wifi}" = "yes"); then
AC_PATH_PROG(WPASUPPLICANT, [wpa_supplicant], [],
$PATH:/sbin:/usr/sbin)
fi
-AM_CONDITIONAL(WIFI, test "${enable_wifi}" = "yes")
+AM_CONDITIONAL(WIFI, test "${enable_wifi}" != "no")
+AM_CONDITIONAL(WIFI_BUILTIN, test "${enable_wifi}" = "builtin")
AC_ARG_ENABLE(bluetooth, AC_HELP_STRING([--enable-bluetooth],
[enable Bluetooth support]), [enable_bluetooth=${enableval}])
-AM_CONDITIONAL(BLUETOOTH, test "${enable_bluetooth}" = "yes")
+AM_CONDITIONAL(BLUETOOTH, test "${enable_bluetooth}" != "no")
+AM_CONDITIONAL(BLUETOOTH_BUILTIN, test "${enable_bluetooth}" = "builtin")
AC_ARG_ENABLE(modemmgr, AC_HELP_STRING([--enable-modemmgr],
[enable Modem Manager support]), [enable_modemmgr=${enableval}])
@@ -115,7 +117,8 @@ if (test "${enable_resolvconf}" = "yes"); then
AC_SUBST(RESOLVCONF)
fi
fi
-AM_CONDITIONAL(RESOLVCONF, test "${enable_resolvconf}" = "yes")
+AM_CONDITIONAL(RESOLVCONF, test "${enable_resolvconf}" != "no")
+AM_CONDITIONAL(RESOLVCONF_BUILTIN, test "${enable_resolvconf}" = "builtin")
AC_ARG_ENABLE(dnsproxy, AC_HELP_STRING([--enable-dnsproxy],
[enable DNS proxy support]), [enable_dnsproxy=${enableval}])