summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorPekka Pessi <Pekka.Pessi@nokia.com>2010-08-17 18:21:09 +0300
committerMarcel Holtmann <marcel@holtmann.org>2010-08-17 17:55:45 +0200
commit4b48dd39d9c1f219e7791b59ca113bc229c25c55 (patch)
treef68ba6110360020f9135b940e7a37c30c5c03ee1 /configure.ac
parenta81257ccf5d17f9733b767c61be84820f4033321 (diff)
downloadconnman-4b48dd39d9c1f219e7791b59ca113bc229c25c55.tar.gz
connman-4b48dd39d9c1f219e7791b59ca113bc229c25c55.tar.bz2
connman-4b48dd39d9c1f219e7791b59ca113bc229c25c55.zip
Always check for ns_initparse
ns_initparse is used by gresolv, too.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 6 insertions, 6 deletions
diff --git a/configure.ac b/configure.ac
index eeda72fd..83aa29ef 100644
--- a/configure.ac
+++ b/configure.ac
@@ -154,12 +154,7 @@ AM_CONDITIONAL(LOOPBACK_BUILTIN, test "${enable_loopback}" = "builtin")
AC_ARG_ENABLE(dnsproxy,
AC_HELP_STRING([--enable-dnsproxy], [enable DNS proxy support]),
[enable_dnsproxy=${enableval}], [enable_dnsproxy="no"])
-if (test "${enable_dnsproxy}" != "no"); then
- AC_CHECK_HEADERS(resolv.h, dummy=yes,
- AC_MSG_ERROR(resolver header files are required))
- AC_CHECK_LIB(resolv, ns_initparse, dummy=yes,
- AC_MSG_ERROR(resolver library support is required))
-fi
+
AM_CONDITIONAL(DNSPROXY, test "${enable_dnsproxy}" != "no")
AM_CONDITIONAL(DNSPROXY_BUILTIN, test "${enable_dnsproxy}" = "builtin")
@@ -175,6 +170,11 @@ AC_ARG_ENABLE(meego,
AM_CONDITIONAL(MEEGO, test "${enable_meego}" != "no")
AM_CONDITIONAL(MEEGO_BUILTIN, test "${enable_meego}" = "builtin")
+AC_CHECK_HEADERS(resolv.h, dummy=yes,
+ AC_MSG_ERROR(resolver header files are required))
+AC_CHECK_LIB(resolv, ns_initparse, dummy=yes,
+ AC_MSG_ERROR(resolver library support is required))
+
AC_CHECK_LIB(dl, dlopen, dummy=yes,
AC_MSG_ERROR(dynamic linking loader is required))