summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorKalle Valo <kalle.valo@canonical.com>2011-01-28 17:02:36 +0200
committerSamuel Ortiz <sameo@linux.intel.com>2011-01-28 16:20:06 +0100
commit298b67120507e9f19fa60e56d8abbe4f870125cc (patch)
tree379fb8af912cab3d5916ac668e478f5ebbfe17b9 /configure.ac
parentdb075ce314d647680cce30d97fc174a3aee02f77 (diff)
downloadconnman-298b67120507e9f19fa60e56d8abbe4f870125cc.tar.gz
connman-298b67120507e9f19fa60e56d8abbe4f870125cc.tar.bz2
connman-298b67120507e9f19fa60e56d8abbe4f870125cc.zip
nmcompat: Add plugin
Add plugin which provides network-manager state interface to applications. This is a direct copy of what was in src/manager.c, just copied all into a plugin.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 6 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 66bee66c..38aa4b43 100644
--- a/configure.ac
+++ b/configure.ac
@@ -274,6 +274,12 @@ fi
AM_CONDITIONAL(NTPD, test "${enable_ntpd}" != "no")
AM_CONDITIONAL(NTPD_BUILTIN, test "${enable_ntpd}" = "builtin")
+AC_ARG_ENABLE(nmcompat,
+ AC_HELP_STRING([--enable-nmcompat], [enable nmcompat support]),
+ [enable_nmcompat=${enableval}], [enable_nmcompat="no"])
+AM_CONDITIONAL(NMCOMPAT, test "${enable_nmcompat}" != "no")
+AM_CONDITIONAL(NMCOMPAT_BUILTIN, test "${enable_nmcompat}" = "builtin")
+
AC_ARG_WITH(stats-max-file-size, AC_HELP_STRING([--with-stats-max-file-size=SIZE],
[Maximal size of a statistics round robin file]),
[stats_max_file_size=${withval}])