summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDaniel Wagner <daniel.wagner@bmw-carit.de>2012-08-13 10:40:23 +0200
committerPatrik Flykt <patrik.flykt@linux.intel.com>2012-08-30 13:01:49 +0300
commitc7cd2709d524d8e5d7ee2f6ec1eff2166b4f1239 (patch)
treeee15ed8f7b2a5b994c627504ebaefeb68d389826 /configure.ac
parent3754e3487c99d2ddd5a5bd672daeca150fda1398 (diff)
downloadconnman-c7cd2709d524d8e5d7ee2f6ec1eff2166b4f1239.tar.gz
connman-c7cd2709d524d8e5d7ee2f6ec1eff2166b4f1239.tar.bz2
connman-c7cd2709d524d8e5d7ee2f6ec1eff2166b4f1239.zip
session: Add configuration plugin
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 6 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 826b3e68..f43b2517 100644
--- a/configure.ac
+++ b/configure.ac
@@ -252,6 +252,12 @@ AC_ARG_ENABLE(tist,
AM_CONDITIONAL(TIST, test "${enable_tist}" != "no")
AM_CONDITIONAL(TIST_BUILTIN, test "${enable_tist}" = "builtin")
+AC_ARG_WITH(configplugin, AC_HELP_STRING([--with-configplugin=PLUGIN],
+ [session config plugin]), [configplugin=${withval}],
+ [configplugin="session_default"])
+SESSION_CONFIG_PLUGIN="$configplugin"
+AC_SUBST(SESSION_CONFIG_PLUGIN)
+
AC_ARG_WITH(stats-max-file-size, AC_HELP_STRING([--with-stats-max-file-size=SIZE],
[Maximal size of a statistics round robin file]),
[stats_max_file_size=${withval}])