summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDaniel Wagner <daniel.wagner@bmw-carit.de>2013-03-18 16:18:12 +0100
committerPatrik Flykt <patrik.flykt@linux.intel.com>2013-03-19 15:53:23 +0200
commitfd7600c2cbebb377124d1aab6a4a2eecc46e14d1 (patch)
tree2b79881fecca15f188065c987033038ef17289ae /configure.ac
parent3b0ff968ff195e8551587e10cb3f1b19a1aa4050 (diff)
downloadconnman-fd7600c2cbebb377124d1aab6a4a2eecc46e14d1.tar.gz
connman-fd7600c2cbebb377124d1aab6a4a2eecc46e14d1.tar.bz2
connman-fd7600c2cbebb377124d1aab6a4a2eecc46e14d1.zip
iptables-unit: Check if rules are inserted/removed
Optionally use iptables-save to check if the rules are installed or removed on the system instead of relying only on the returned iptables error code. Do notice that running tools/iptables-unit will modify and delete existing iptables firewall rules on your system. Use iptables-unit with caution!
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 9 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 4baeee0a..9b09c2c3 100644
--- a/configure.ac
+++ b/configure.ac
@@ -340,6 +340,15 @@ AC_ARG_ENABLE(tools, AC_HELP_STRING([--disable-tools],
[enable_tools=${enableval}])
AM_CONDITIONAL(TOOLS, test "${enable_tools}" != "no")
+if (test "${enable_tools}" != "no"); then
+ AC_PATH_PROGS(IPTABLES_SAVE, [iptables-save], [],
+ $PATH:/sbin:/usr/sbin)
+ IPTABLES_SAVE=$ac_cv_path_IPTABLES_SAVE
+else
+ IPTABLES_SAVE=""
+fi
+AC_SUBST(IPTABLES_SAVE)
+
AC_ARG_ENABLE(client, AC_HELP_STRING([--disable-client],
[disable command line client]),
[enable_client=${enableval}])