summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJukka Rissanen <jukka.rissanen@linux.intel.com>2012-11-12 14:07:58 +0200
committerPatrik Flykt <patrik.flykt@linux.intel.com>2012-11-23 12:58:52 +0200
commitacedf9d49b9a326771aeec755179e3ede3872cdd (patch)
treeb4eff171ca55eb9a4cb1d9fdfd9f6638848e051c /configure.ac
parent9b45848a88af4ae202bce346062a7c8db9bc6a66 (diff)
downloadconnman-acedf9d49b9a326771aeec755179e3ede3872cdd.tar.gz
connman-acedf9d49b9a326771aeec755179e3ede3872cdd.tar.bz2
connman-acedf9d49b9a326771aeec755179e3ede3872cdd.zip
selinux: Add Type Enforcement rule compilation
The SELinux rules are needed for VPN. They allow various vpn clients to send notifications to connman-vpnd via net.connman.Task dbus interface if the connman processes are run under systemd and the system is in enforcing mode.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 5 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 51df9d60..87580c45 100644
--- a/configure.ac
+++ b/configure.ac
@@ -343,6 +343,11 @@ if (test "${enable_polkit}" != "no"); then
fi
AM_CONDITIONAL(POLKIT, test "${enable_polkit}" != "no")
+AC_ARG_ENABLE(selinux, AC_HELP_STRING([--enable-selinux],
+ [enable selinux support]),
+ [enable_selinux=${enableval}], [enable_selinux="no"])
+AM_CONDITIONAL(SELINUX, test "${enable_selinux}" != "no")
+
AC_ARG_ENABLE(loopback, AC_HELP_STRING([--disable-loopback],
[disable loopback support]),
[enable_loopback=${enableval}])