summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMarcel Holtmann <marcel@holtmann.org>2008-10-07 14:23:28 +0200
committerMarcel Holtmann <marcel@holtmann.org>2008-10-07 14:23:28 +0200
commit8dd59fd33eed869fcb2597b3962b8d3cba9c5efa (patch)
tree1cc66a5dbc169058e0928110151e3abe5177fe28 /configure.ac
parent6fa6bdc6f6a8d239142b32979318245da8941d2b (diff)
downloadconnman-8dd59fd33eed869fcb2597b3962b8d3cba9c5efa.tar.gz
connman-8dd59fd33eed869fcb2597b3962b8d3cba9c5efa.tar.bz2
connman-8dd59fd33eed869fcb2597b3962b8d3cba9c5efa.zip
Include fake plugin for testing
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 61e6418c..5857197a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -85,6 +85,10 @@ PKG_CHECK_MODULES(SQLITE, sqlite3, sqlite_found=yes, sqlite_found=no)
AC_SUBST(SQLITE_CFLAGS)
AC_SUBST(SQLITE_LIBS)
+AC_ARG_ENABLE(fake, AC_HELP_STRING([--enable-fake],
+ [enable fake plugin]), [enable_fake=${enableval}])
+AM_CONDITIONAL(FAKE, test "${enable_fake}" = "yes")
+
AC_OUTPUT(Makefile gdbus/Makefile include/Makefile src/Makefile doc/Makefile
test/Makefile plugins/Makefile scripts/Makefile scripts/connman
src/connman.service doc/version.xml connman.pc)