summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMohamed Abbas <mohamed.abbas@intel.com>2010-03-25 00:04:49 +0100
committerSamuel Ortiz <sameo@linux.intel.com>2010-03-25 00:46:32 +0100
commit989648e9db2dda93a464125c0d0540cdf10158f7 (patch)
tree10cd1df42118926855556f6461902ac0c8b29f94 /configure.ac
parent495e4684729e7dd35b92524246d155b5f852cffe (diff)
downloadconnman-989648e9db2dda93a464125c0d0540cdf10158f7.tar.gz
connman-989648e9db2dda93a464125c0d0540cdf10158f7.tar.bz2
connman-989648e9db2dda93a464125c0d0540cdf10158f7.zip
Portal detection plugin
Add new plugin to support page redirection when using wifi or ethernet. Most of this code is a copy from tools/portal-test.com intergrated to work with location core.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 6 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index d210c8ad..af498d0e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -160,6 +160,12 @@ fi
AM_CONDITIONAL(OPENCONNECT, test "${enable_openconnect}" != "no")
AM_CONDITIONAL(OPENCONNECT_BUILTIN, test "${enable_openconnect}" = "builtin")
+AC_ARG_ENABLE(portal,
+ AC_HELP_STRING([--enable-portal], [enable portal detection support]),
+ [enable_portal=${enableval}], [enable_portal="no"])
+AM_CONDITIONAL(PORTAL, test "${enable_portal}" != "no")
+AM_CONDITIONAL(PORTAL_BUILTIN, test "${enable_portal}" = "builtin")
+
AC_ARG_ENABLE(loopback,
AC_HELP_STRING([--enable-loopback], [enable loopback support]),
[enable_loopback=${enableval}], [enable_loopback="no"])