summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMarcel Holtmann <marcel@holtmann.org>2009-01-08 21:02:04 +0100
committerMarcel Holtmann <marcel@holtmann.org>2009-01-08 21:02:04 +0100
commit8e888241130e35ee140ba6c184d0ceff1598c430 (patch)
tree7b62dec9380a88588bf6a9fb00d1c597835a0ddb /configure.ac
parent6281c3a0f6026a77d68026c0e14c49b825fab2ef (diff)
downloadconnman-8e888241130e35ee140ba6c184d0ceff1598c430.tar.gz
connman-8e888241130e35ee140ba6c184d0ceff1598c430.tar.bz2
connman-8e888241130e35ee140ba6c184d0ceff1598c430.zip
Add support for reading policy directory from polkit.pc
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 5 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 1d8fc5ed..223e1e0f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -198,6 +198,11 @@ if (test "${enable_polkit}" = "yes"); then
AC_MSG_ERROR(PolicyKit >= 0.7 is required))
AC_SUBST(POLKIT_CFLAGS)
AC_SUBST(POLKIT_LIBS)
+ POLKIT_DATADIR="`pkg-config --variable=policydir polkit`"
+ if (test -z "${POLKIT_DATADIR}"); then
+ POLKIT_DATADIR="${datadir}/PolicyKit/policy"
+ fi
+ AC_SUBST(POLKIT_DATADIR)
fi
AM_CONDITIONAL(POLKIT, test "${enable_polkit}" = "yes")