summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMarcel Holtmann <marcel@holtmann.org>2009-01-08 21:09:18 +0100
committerMarcel Holtmann <marcel@holtmann.org>2009-01-08 21:09:18 +0100
commit049eae8ec20f0b3dd37d6f4b843da318966d4346 (patch)
tree7e0f7a556618d9296ecde275ef3f6f144cba1789 /configure.ac
parent8e888241130e35ee140ba6c184d0ceff1598c430 (diff)
downloadconnman-049eae8ec20f0b3dd37d6f4b843da318966d4346.tar.gz
connman-049eae8ec20f0b3dd37d6f4b843da318966d4346.tar.bz2
connman-049eae8ec20f0b3dd37d6f4b843da318966d4346.zip
Add support for reading rules directory from libudev.pc
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 5 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 223e1e0f..a6cc07cc 100644
--- a/configure.ac
+++ b/configure.ac
@@ -186,6 +186,11 @@ if (test "${enable_udev}" = "yes"); then
[Define to 1 if you need the
udev_device_get_parent_with_subsystem_devtype()
function.]))
+ UDEV_DATADIR="`pkg-config --variable=rulesdir libudev`"
+ if (test -z "${UDEV_DATADIR}"); then
+ UDEV_DATADIR="${sysconfdir}/udev/rules.d"
+ fi
+ AC_SUBST(UDEV_DATADIR)
fi
AC_SUBST(UDEV_CFLAGS)
AC_SUBST(UDEV_LIBS)