summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMarcel Holtmann <marcel@holtmann.org>2010-10-29 20:08:05 +0200
committerMarcel Holtmann <marcel@holtmann.org>2010-10-29 20:08:05 +0200
commit1eed303ab1717b25eba1c05a708eae9625af6efc (patch)
tree2c92926f8a800b59634bc089436e4325adbdd931 /configure.ac
parent0663c1943f5cbbcb7e887d9f312b77059ed21ca5 (diff)
downloadconnman-1eed303ab1717b25eba1c05a708eae9625af6efc.tar.gz
connman-1eed303ab1717b25eba1c05a708eae9625af6efc.tar.bz2
connman-1eed303ab1717b25eba1c05a708eae9625af6efc.zip
Check for GnuTLS library when tools are enabled
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 6 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index f36a7662..1f406f07 100644
--- a/configure.ac
+++ b/configure.ac
@@ -317,7 +317,7 @@ fi
AC_SUBST(DBUS_DATADIR)
PKG_CHECK_MODULES(XTABLES, xtables, dummy=yes,
- AC_MSG_ERROR(xtables library is required))
+ AC_MSG_ERROR(Xtables library is required))
AC_SUBST(XTABLES_CFLAGS)
AC_SUBST(XTABLES_LIBS)
@@ -360,6 +360,11 @@ if (test "${enable_tools}" = "yes"); then
AC_MSG_ERROR(Netlink library is required))
AC_SUBST(NETLINK_CFLAGS)
AC_SUBST(NETLINK_LIBS)
+
+ PKG_CHECK_MODULES(GNUTLS, gnutls, dummy=yes,
+ AC_MSG_ERROR(GnuTLS library is required))
+ AC_SUBST(GNUTLS_CFLAGS)
+ AC_SUBST(GNUTLS_LIBS)
fi
AM_CONDITIONAL(TOOLS, test "${enable_tools}" = "yes")