summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMarcel Holtmann <marcel@holtmann.org>2010-07-13 23:03:24 -0300
committerMarcel Holtmann <marcel@holtmann.org>2010-07-13 23:03:24 -0300
commitf69968a60146d1594e62a0b9794e2862ea6dc115 (patch)
tree94c7cab80649981bdcf90b14bd80a465e717bb96 /configure.ac
parent0378026fe391c3312b2ad263af77c2f5639c5dd8 (diff)
downloadconnman-f69968a60146d1594e62a0b9794e2862ea6dc115.tar.gz
connman-f69968a60146d1594e62a0b9794e2862ea6dc115.tar.bz2
connman-f69968a60146d1594e62a0b9794e2862ea6dc115.zip
Add some extra autoconf/automake magic for iptables library
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 5 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 65144834..f1377491 100644
--- a/configure.ac
+++ b/configure.ac
@@ -347,6 +347,11 @@ AM_CONDITIONAL(CLIENT, test "${enable_client}" = "yes")
AC_ARG_ENABLE(tools, AC_HELP_STRING([--enable-tools],
[enable testing tools]), [enable_tools=${enableval}])
if (test "${enable_tools}" = "yes"); then
+ PKG_CHECK_MODULES(IPTC, libiptc, dummy=yes,
+ AC_MSG_ERROR(iptables library is required))
+ AC_SUBST(IPTC_CFLAGS)
+ AC_SUBST(IPTC_LIBS)
+
PKG_CHECK_MODULES(NETLINK, libnl-1, dummy=yes,
AC_MSG_ERROR(Netlink library is required))
AC_SUBST(NETLINK_CFLAGS)