summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorSamuel Ortiz <sameo@linux.intel.com>2010-05-31 15:09:28 +0200
committerSamuel Ortiz <sameo@linux.intel.com>2010-05-31 17:39:56 +0200
commitec6dc19bbeb4c93e951ba5419ccf6768d5811ae6 (patch)
tree1673a4b201f6f6cdc1d5277a5c2821cb569f9d5a /configure.ac
parentdba90159b8bf8f065fcbce48432ef5da36a0c5ce (diff)
downloadconnman-ec6dc19bbeb4c93e951ba5419ccf6768d5811ae6.tar.gz
connman-ec6dc19bbeb4c93e951ba5419ccf6768d5811ae6.tar.bz2
connman-ec6dc19bbeb4c93e951ba5419ccf6768d5811ae6.zip
ntpd plugin
The ntpd plugin triggers an ntpd -q task whenever a service goes online. It either uses the meego ntp service or the one it potentially fetches from a DHCP response.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac18
1 files changed, 18 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index fc0c519f..13c1a3a5 100644
--- a/configure.ac
+++ b/configure.ac
@@ -280,6 +280,24 @@ AC_ARG_ENABLE(iospm, AC_HELP_STRING([--enable-iospm],
[enable Intel OSPM support]), [enable_iospm=${enableval}])
AM_CONDITIONAL(IOSPM, test "${enable_iospm}" = "yes")
+AC_ARG_WITH(ntpd, AC_HELP_STRING([--with-=PROGRAM],
+ [specify ntpd binary location]), [path_ntpd=${withval}])
+
+AC_ARG_ENABLE(ntpd,
+ AC_HELP_STRING([--enable-ntpd], [enable ntpd support]),
+ [enable_ntpd=${enableval}], [enable_ntpd="no"])
+
+if (test "${enable_ntpd}" != "no"); then
+ if (test -z "${path_ntpd}"); then
+ AC_PATH_PROG(NTPD, [ntpd], [], $PATH:/sbin:/usr/sbin)
+ else
+ NTPD="${path_ntpd}"
+ AC_SUBST(NTPD)
+ fi
+fi
+AM_CONDITIONAL(NTPD, test "${enable_ntpd}" != "no")
+AM_CONDITIONAL(NTPD_BUILTIN, test "${enable_ntpd}" = "builtin")
+
PKG_CHECK_MODULES(GLIB, glib-2.0 >= 2.16, dummy=yes,
AC_MSG_ERROR(GLib >= 2.16 is required))
AC_SUBST(GLIB_CFLAGS)