summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorPatrik Flykt <patrik.flykt@linux.intel.com>2011-10-06 16:08:10 +0300
committerSamuel Ortiz <sameo@linux.intel.com>2011-10-07 19:51:02 +0200
commit5113da15429a5787391bc5348c87c662b15c247e (patch)
tree27ee7b1ebeebe0bd6014cc8fd8bd8e5ccacc2616 /configure.ac
parent38a5212e282826ff57b6992f0c2b77e05aab5705 (diff)
downloadconnman-5113da15429a5787391bc5348c87c662b15c247e.tar.gz
connman-5113da15429a5787391bc5348c87c662b15c247e.tar.bz2
connman-5113da15429a5787391bc5348c87c662b15c247e.zip
configure: Print errors if VPN binaries are not found
When a VPN has been enabled and its binary is not given with '--with-<VPN>=PROGRAM', make an additional check whether AC_PATH_PROG found the binary in question.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 9 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 32b9d198..280e587c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -104,6 +104,9 @@ AC_ARG_ENABLE(openconnect,
if (test "${enable_openconnect}" != "no"); then
if (test -z "${path_openconnect}"); then
AC_PATH_PROG(OPENCONNECT, [openconnect], [], $PATH:/sbin:/usr/sbin)
+ if (test -z "${OPENCONNECT}"); then
+ AC_MSG_ERROR(openconnect binary not found)
+ fi
else
OPENCONNECT="${path_openconnect}"
AC_SUBST(OPENCONNECT)
@@ -121,6 +124,9 @@ AC_ARG_ENABLE(openvpn,
if (test "${enable_openvpn}" != "no"); then
if (test -z "${path_openvpn}"); then
AC_PATH_PROG(OPENVPN, [openvpn], [], $PATH:/sbin:/usr/sbin)
+ if (test -z "${OPENVPN}"); then
+ AC_MSG_ERROR(openvpn binary not found)
+ fi
else
OPENVPN="${path_openvpn}"
AC_SUBST(OPENVPN)
@@ -138,6 +144,9 @@ AC_ARG_ENABLE(vpnc,
if (test "${enable_vpnc}" != "no"); then
if (test -z "${path_vpnc}"); then
AC_PATH_PROG(VPNC, [vpnc], [], $PATH:/sbin:/usr/sbin)
+ if (test -z "${VPNC}"); then
+ AC_MSG_ERROR(vpnc binary not found)
+ fi
else
VPNC="${path_vpnc}"
AC_SUBST(VPNC)