summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMarcel Holtmann <marcel@holtmann.org>2009-04-27 23:59:46 -0700
committerMarcel Holtmann <marcel@holtmann.org>2009-04-27 23:59:46 -0700
commit47bd0ee5afe38109771623335a5272f682432c5a (patch)
treecc68bf8c15b10d8c13c253368d2ee2d8ace3668f /configure.ac
parent5e8e434393bdb77bf634c99c9d18b4e45be8fd82 (diff)
downloadconnman-47bd0ee5afe38109771623335a5272f682432c5a.tar.gz
connman-47bd0ee5afe38109771623335a5272f682432c5a.tar.bz2
connman-47bd0ee5afe38109771623335a5272f682432c5a.zip
Allow selective option for current built-in plugins
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 6 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index daa40c39..2bcac75f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -48,11 +48,13 @@ AC_ARG_ENABLE(threads, AC_HELP_STRING([--enable-threads],
AC_ARG_ENABLE(loopback, AC_HELP_STRING([--enable-loopback],
[enable loopback support]), [enable_loopback=${enableval}])
-AM_CONDITIONAL(LOOPBACK, test "${enable_loopback}" = "yes")
+AM_CONDITIONAL(LOOPBACK, test "${enable_loopback}" != "no")
+AM_CONDITIONAL(LOOPBACK_BUILTIN, test "${enable_loopback}" = "builtin")
AC_ARG_ENABLE(ethernet, AC_HELP_STRING([--enable-ethernet],
[enable Ethernet support]), [enable_ethernet=${enableval}])
-AM_CONDITIONAL(ETHERNET, test "${enable_ethernet}" = "yes")
+AM_CONDITIONAL(ETHERNET, test "${enable_ethernet}" != "no")
+AM_CONDITIONAL(ETHERNET_BUILTIN, test "${enable_ethernet}" = "builtin")
AC_ARG_ENABLE(wifi, AC_HELP_STRING([--enable-wifi],
[enable WiFi support]), [enable_wifi=${enableval}])
@@ -117,7 +119,8 @@ AM_CONDITIONAL(RESOLVCONF, test "${enable_resolvconf}" = "yes")
AC_ARG_ENABLE(dnsproxy, AC_HELP_STRING([--enable-dnsproxy],
[enable DNS proxy support]), [enable_dnsproxy=${enableval}])
-AM_CONDITIONAL(DNSPROXY, test "${enable_dnsproxy}" = "yes")
+AM_CONDITIONAL(DNSPROXY, test "${enable_dnsproxy}" != "no")
+AM_CONDITIONAL(DNSPROXY_BUILTIN, test "${enable_dnsproxy}" = "builtin")
AC_ARG_ENABLE(novatel, AC_HELP_STRING([--enable-novatel],
[enable Novatel support]), [enable_novatel=${enableval}])