summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMarcel Holtmann <marcel@holtmann.org>2009-01-08 21:40:58 +0100
committerMarcel Holtmann <marcel@holtmann.org>2009-01-08 21:40:58 +0100
commitb0799835aa141dd9f32d1d477e113507f8b47522 (patch)
tree49e4d6c23a7b417ce84d3bfcf16aad6d8984ee07 /configure.ac
parent0f3e594a00cbe7922640a4dc338fed62226c9243 (diff)
downloadconnman-b0799835aa141dd9f32d1d477e113507f8b47522.tar.gz
connman-b0799835aa141dd9f32d1d477e113507f8b47522.tar.bz2
connman-b0799835aa141dd9f32d1d477e113507f8b47522.zip
Use $PKG_CONFIG instead of pkg-config
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 3 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 96d37589..8e6fa946 100644
--- a/configure.ac
+++ b/configure.ac
@@ -167,7 +167,7 @@ PKG_CHECK_MODULES(DBUS, dbus-1 >= 1.0, dummy=yes,
AC_MSG_ERROR(libdbus is required))
AC_SUBST(DBUS_CFLAGS)
AC_SUBST(DBUS_LIBS)
-DBUS_DATADIR="`pkg-config --variable=sysconfdir dbus-1`"
+DBUS_DATADIR="`$PKG_CONFIG --variable=sysconfdir dbus-1`"
if (test -z "{DBUS_DATADIR}"); then
DBUS_DATADIR="${sysconfdir}/dbus-1/system.d"
else
@@ -193,7 +193,7 @@ if (test "${enable_udev}" = "yes"); then
[Define to 1 if you need the
udev_device_get_parent_with_subsystem_devtype()
function.]))
- UDEV_DATADIR="`pkg-config --variable=rulesdir libudev`"
+ UDEV_DATADIR="`$PKG_CONFIG --variable=rulesdir libudev`"
if (test -z "${UDEV_DATADIR}"); then
UDEV_DATADIR="${sysconfdir}/udev/rules.d"
fi
@@ -210,7 +210,7 @@ if (test "${enable_polkit}" = "yes"); then
AC_MSG_ERROR(PolicyKit >= 0.7 is required))
AC_SUBST(POLKIT_CFLAGS)
AC_SUBST(POLKIT_LIBS)
- POLKIT_DATADIR="`pkg-config --variable=policydir polkit`"
+ POLKIT_DATADIR="`$PKG_CONFIG --variable=policydir polkit`"
if (test -z "${POLKIT_DATADIR}"); then
POLKIT_DATADIR="${datadir}/PolicyKit/policy"
fi