summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMarcel Holtmann <marcel@holtmann.org>2009-01-02 22:16:44 +0100
committerMarcel Holtmann <marcel@holtmann.org>2009-01-02 22:16:44 +0100
commit5bbbce97de441f908dfdb738f8816b31153b75b4 (patch)
tree646256e9f489aee4d4835b59e71129c3173de206 /configure.ac
parent0a23309f85839e8cd1c65b53e8e5ff07bf588d4c (diff)
downloadconnman-5bbbce97de441f908dfdb738f8816b31153b75b4.tar.gz
connman-5bbbce97de441f908dfdb738f8816b31153b75b4.tar.bz2
connman-5bbbce97de441f908dfdb738f8816b31153b75b4.zip
Add configure switch for HUAWEI support
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 5 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 77197de7..f114c114 100644
--- a/configure.ac
+++ b/configure.ac
@@ -62,13 +62,17 @@ if (test "${enable_wifi}" = "yes"); then
fi
AM_CONDITIONAL(WIFI, test "${enable_wifi}" = "yes")
+AC_ARG_ENABLE(huawei, AC_HELP_STRING([--enable-huawei],
+ [enable HUAWEI support]), [enable_huawei=${enableval}])
+AM_CONDITIONAL(HUAWEI, test "${enable_huawei}" = "yes")
+
AC_ARG_ENABLE(hso, AC_HELP_STRING([--enable-hso],
[enable HSO support]), [enable_hso=${enableval}])
AM_CONDITIONAL(HSO, test "${enable_hso}" = "yes")
AC_ARG_ENABLE(ppp, AC_HELP_STRING([--enable-ppp],
[enable PPP support]), [enable_ppp=${enableval}])
-if (test "${enable_ppp}" = "yes"); then
+if (test "${enable_ppp}" = "yes" || test "${enable_huawei}" = "yes"); then
AC_PATH_PROG(PPPD, [pppd], [], $PATH:/sbin:/usr/sbin)
AC_CHECK_HEADERS(pppd/pppd.h, enable_ppp=yes,
AC_MSG_ERROR(PPP development files are required))