summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorJukka Rissanen <jukka.rissanen@linux.intel.com>2012-11-12 14:07:18 +0200
committerPatrik Flykt <patrik.flykt@linux.intel.com>2012-11-23 12:58:50 +0200
commit68dde4bb2c3e90a6f48dc48609636228dd186c8c (patch)
tree319e4787674daa49b939916769611f0770a32e91 /Makefile.am
parentd20247d3b3074b7c5937540ce5dbc8f020c79907 (diff)
downloadconnman-68dde4bb2c3e90a6f48dc48609636228dd186c8c.tar.gz
connman-68dde4bb2c3e90a6f48dc48609636228dd186c8c.tar.bz2
connman-68dde4bb2c3e90a6f48dc48609636228dd186c8c.zip
ipconfig: Move IP address API into separate ipaddress.c file
Done so that connman_ipaddress_* functions can be used from separate vpn daemon.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index b845d6e2..a489c852 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -8,7 +8,7 @@ include_HEADERS = include/types.h include/log.h include/plugin.h \
include/resolver.h include/ipconfig.h \
include/device.h include/network.h include/inet.h \
include/storage.h include/provision.h \
- include/session.h
+ include/session.h include/ipaddress.h
nodist_include_HEADERS = include/version.h
@@ -85,7 +85,7 @@ src_connmand_SOURCES = $(gdbus_sources) $(gdhcp_sources) $(gweb_sources) \
src/technology.c src/counter.c src/ntp.c \
src/session.c src/tethering.c src/wpad.c src/wispr.c \
src/stats.c src/iptables.c src/dnsproxy.c src/6to4.c \
- src/ippool.c src/bridge.c src/nat.c
+ src/ippool.c src/bridge.c src/nat.c src/ipaddress.c
src_connmand_LDADD = $(builtin_libadd) @GLIB_LIBS@ @DBUS_LIBS@ \
@XTABLES_LIBS@ @GNUTLS_LIBS@ -lresolv -ldl -lrt