summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorMarcel Holtmann <marcel@holtmann.org>2012-05-21 22:12:28 +0200
committerMarcel Holtmann <marcel@holtmann.org>2012-05-21 22:12:28 +0200
commit78b10682561c8b657be8348a7bedcd2ed7858d84 (patch)
tree635cc8ade98449142225edc782e65602b731ccea /Makefile.am
parentbb411f47ec30cb02edb4c13f15f14d76a3c1103c (diff)
downloadconnman-78b10682561c8b657be8348a7bedcd2ed7858d84.tar.gz
connman-78b10682561c8b657be8348a7bedcd2ed7858d84.tar.bz2
connman-78b10682561c8b657be8348a7bedcd2ed7858d84.zip
build: Add option for disabling WISPr support
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am28
1 files changed, 17 insertions, 11 deletions
diff --git a/Makefile.am b/Makefile.am
index 9eeb2f5c..9d713aec 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -27,8 +27,13 @@ gdbus_sources = gdbus/gdbus.h gdbus/mainloop.c gdbus/watch.c \
gdhcp_sources = gdhcp/gdhcp.h gdhcp/common.h gdhcp/common.c gdhcp/client.c \
gdhcp/server.c gdhcp/ipv4ll.h gdhcp/ipv4ll.c
-gweb_sources = gweb/gweb.h gweb/gweb.c gweb/gresolv.h gweb/gresolv.c \
- gweb/giognutls.h gweb/giognutls.c
+gweb_sources = gweb/gweb.h gweb/gweb.c gweb/gresolv.h gweb/gresolv.c
+
+if WISPR
+gweb_sources += gweb/giognutls.h gweb/giognutls.c
+else
+gweb_sources += gweb/giognutls.h gweb/gionotls.c
+endif
if DATAFILES
@@ -62,10 +67,7 @@ unit_objects =
sbin_PROGRAMS = src/connmand
-src_connmand_SOURCES = $(gdbus_sources) $(gdhcp_sources) \
- gweb/gweb.h gweb/gweb.c \
- gweb/gresolv.h gweb/gresolv.c \
- gweb/giognutls.h gweb/giognutls.c \
+src_connmand_SOURCES = $(gdbus_sources) $(gdhcp_sources) $(gweb_sources) \
$(builtin_sources) src/connman.ver \
src/main.c src/connman.h src/log.c \
src/error.c src/plugin.c src/task.c \
@@ -122,7 +124,7 @@ AM_CFLAGS = @DBUS_CFLAGS@ @GLIB_CFLAGS@ @XTABLES_CFLAGS@ \
INCLUDES = -I$(builddir)/include -I$(builddir)/src -I$(srcdir)/gdbus
EXTRA_DIST = src/genbuiltin src/connman-dbus.conf src/connman-polkit.conf \
- plugins/connman-nmcompat.conf gweb/gionotls.c
+ plugins/connman-nmcompat.conf
script_DATA =
@@ -138,8 +140,15 @@ client_cm_SOURCES = client/main.c
client_cm_LDADD = @DBUS_LIBS@
endif
+if WISPR
+noinst_PROGRAMS += tools/wispr
+
+tools_wispr_SOURCES = $(gweb_sources) tools/wispr.c
+tools_wispr_LDADD = @GLIB_LIBS@ @GNUTLS_LIBS@ -lresolv
+endif
+
if TOOLS
-noinst_PROGRAMS += tools/wispr tools/supplicant-test \
+noinst_PROGRAMS += tools/supplicant-test \
tools/dhcp-test tools/dhcp-server-test \
tools/addr-test tools/web-test tools/resolv-test \
tools/dbus-test tools/polkit-test \
@@ -147,9 +156,6 @@ noinst_PROGRAMS += tools/wispr tools/supplicant-test \
tools/stats-tool tools/private-network-test \
unit/test-session unit/test-ippool unit/test-nat
-tools_wispr_SOURCES = $(gweb_sources) tools/wispr.c
-tools_wispr_LDADD = @GLIB_LIBS@ @GNUTLS_LIBS@ -lresolv
-
tools_supplicant_test_SOURCES = $(gdbus_sources) tools/supplicant-test.c \
tools/supplicant-dbus.h tools/supplicant-dbus.c \
tools/supplicant.h tools/supplicant.c