summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorCeara Chewning <ceara.k.chewning@intel.com>2012-09-12 15:06:00 -0700
committerPatrik Flykt <patrik.flykt@linux.intel.com>2012-09-14 16:32:00 +0300
commit42d7ba8fdeab32d0e7f492c689711a85e8ea94f2 (patch)
tree5cbd0ee4d74041815dce4a0aa961cf5ed1788f65 /Makefile.am
parent473df03bb1d0b5d00579a28a10386aded82bc63f (diff)
downloadconnman-42d7ba8fdeab32d0e7f492c689711a85e8ea94f2.tar.gz
connman-42d7ba8fdeab32d0e7f492c689711a85e8ea94f2.tar.bz2
connman-42d7ba8fdeab32d0e7f492c689711a85e8ea94f2.zip
client: Update Makefile.am and add new command line client main file
The new main.c uses the previously added services, technology, manager, interactive, and monitor files to create the connmanctl command line interface. It is able to display properties of services and technologies, and set/enable them.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am17
1 files changed, 14 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index 5c5b95ca..fe8e75dc 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -135,10 +135,21 @@ script_LTLIBRARIES =
include Makefile.plugins
if CLIENT
-noinst_PROGRAMS += client/cm
+noinst_PROGRAMS += client/connmanctl
-client_cm_SOURCES = client/main.c
-client_cm_LDADD = @DBUS_LIBS@
+dist_man_MANS = doc/connmanctl.1
+
+client_connmanctl_SOURCES = $(gdbus_sources) src/connman.h \
+ include/log.h src/log.c \
+ include/dbus.h src/dbus.c \
+ client/data_manager.h client/data_manager.c \
+ client/services.h client/services.c \
+ client/technology.h client/technology.c \
+ client/interactive.h client/interactive.c \
+ client/monitor.h client/monitor.c \
+ client/commands.c client/main.c
+
+client_connmanctl_LDADD = @DBUS_LIBS@ @GLIB_LIBS@ -lreadline -ldl
endif
if WISPR