summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorDaniel Wagner <daniel.wagner@bmw-carit.de>2012-02-01 18:51:46 +0100
committerSamuel Ortiz <sameo@linux.intel.com>2012-02-13 11:33:17 +0100
commit37cbd6d1e4f65892bab87194479a3cf86fa181aa (patch)
treeb94b0033f0055021a7e66b3e3b65972932b91d95 /Makefile.am
parentd9a94c8478156c97f9cca85d824964994a9b54bf (diff)
downloadconnman-37cbd6d1e4f65892bab87194479a3cf86fa181aa.tar.gz
connman-37cbd6d1e4f65892bab87194479a3cf86fa181aa.tar.bz2
connman-37cbd6d1e4f65892bab87194479a3cf86fa181aa.zip
nat: Move nat code into a seperate file
Instead of natting all traffic, nat.c will restrict the masquerading on given network/mask. The nat handling code will be reused by session.c
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 5a70f0c0..79b4f9f6 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -80,7 +80,7 @@ src_connmand_SOURCES = $(gdbus_sources) $(gdhcp_sources) \
src/technology.c src/counter.c src/ntp.c \
src/session.c src/tethering.c src/wpad.c src/wispr.c \
src/stats.c src/iptables.c src/dnsproxy.c src/6to4.c \
- src/ippool.c src/bridge.c
+ src/ippool.c src/bridge.c src/nat.c
src_connmand_LDADD = $(builtin_libadd) @GLIB_LIBS@ @DBUS_LIBS@ \
@CAPNG_LIBS@ @XTABLES_LIBS@ -lresolv -ldl