summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorDaniel Wagner <daniel.wagner@bmw-carit.de>2012-02-01 18:51:47 +0100
committerSamuel Ortiz <sameo@linux.intel.com>2012-02-13 11:33:17 +0100
commit2e6ad171779854947b4e2917e17e59ee90a81626 (patch)
treefe2e144f793f0dd3db7230981c7571dc3f1815b8 /Makefile.am
parent37cbd6d1e4f65892bab87194479a3cf86fa181aa (diff)
downloadconnman-2e6ad171779854947b4e2917e17e59ee90a81626.tar.gz
connman-2e6ad171779854947b4e2917e17e59ee90a81626.tar.bz2
connman-2e6ad171779854947b4e2917e17e59ee90a81626.zip
test-nat: Add nat unit test
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am8
1 files changed, 7 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 79b4f9f6..dcf3d514 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -145,7 +145,8 @@ noinst_PROGRAMS += tools/wispr tools/supplicant-test \
tools/dbus-test tools/polkit-test \
tools/iptables-test tools/tap-test tools/wpad-test \
tools/stats-tool tools/private-network-test \
- tools/alg-test unit/test-session unit/test-ippool
+ tools/alg-test unit/test-session unit/test-ippool \
+ unit/test-nat
tools_wispr_SOURCES = $(gweb_sources) tools/wispr.c
tools_wispr_LDADD = @GLIB_LIBS@ @GNUTLS_LIBS@ -lresolv
@@ -193,6 +194,11 @@ unit_test_ippool_SOURCES = $(gdbus_sources) src/log.c src/dbus.c \
src/ippool.c unit/test-ippool.c
unit_test_ippool_LDADD = @GLIB_LIBS@ @DBUS_LIBS@ -ldl
unit_objects += $(unit_test_ippool_OBJECTS)
+
+unit_test_nat_SOURCES = $(gdbus_sources) src/log.c src/dbus.c \
+ src/iptables.c src/nat.c unit/test-nat.c
+unit_test_nat_LDADD = @GLIB_LIBS@ @DBUS_LIBS@ @XTABLES_LIBS@ -ldl
+unit_objects += $(unit_nat_ippool_OBJECTS)
endif
test_scripts = test/get-state test/list-services \