summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorDaniel Wagner <daniel.wagner@bmw-carit.de>2012-01-26 16:03:32 +0100
committerDaniel Wagner <daniel.wagner@bmw-carit.de>2012-02-01 10:13:19 +0100
commit29bfea7322a0af957f3cc3e478d2ff44e892d061 (patch)
tree3eb907c33d37b631a908ad60e333683c28003d46 /Makefile.am
parentabdb18855f7981fb740f8db89f2356c572dab484 (diff)
downloadconnman-29bfea7322a0af957f3cc3e478d2ff44e892d061.tar.gz
connman-29bfea7322a0af957f3cc3e478d2ff44e892d061.tar.bz2
connman-29bfea7322a0af957f3cc3e478d2ff44e892d061.zip
test-ippool: Add unit test for ippool
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am7
1 files changed, 6 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 4bb85cf3..49f10fc5 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -145,7 +145,7 @@ noinst_PROGRAMS += tools/wispr tools/supplicant-test \
tools/dbus-test tools/polkit-test \
tools/iptables-test tools/tap-test tools/wpad-test \
tools/stats-tool tools/private-network-test \
- tools/alg-test unit/test-session
+ tools/alg-test unit/test-session unit/test-ippool
tools_wispr_SOURCES = $(gweb_sources) tools/wispr.c
tools_wispr_LDADD = @GLIB_LIBS@ @GNUTLS_LIBS@ -lresolv
@@ -188,6 +188,11 @@ unit_test_session_SOURCES = $(gdbus_sources) src/log.c src/dbus.c \
unit/session-api.c unit/test-connman.h
unit_test_session_LDADD = @GLIB_LIBS@ @DBUS_LIBS@ -ldl
unit_objects += $(unit_test_session_OBJECTS)
+
+unit_test_ippool_SOURCES = $(gdbus_sources) src/log.c src/dbus.c \
+ src/ippool.c unit/test-ippool.c
+unit_test_ippool_LDADD = @GLIB_LIBS@ @DBUS_LIBS@ -ldl
+unit_objects += $(unit_test_ippool_OBJECTS)
endif
test_scripts = test/get-state test/list-services \