summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorSaurav Babu <saurav.babu@samsung.com>2017-09-05 12:29:22 +0530
committerSaurav Babu <saurav.babu@samsung.com>2017-09-05 12:29:22 +0530
commit9e3b1931585c316b741f4daac44511f856d6ca77 (patch)
treeff35096062c84d03569ad7594f7b218e18cbced5 /Makefile.am
parentbd09a474c0ed005aae50bb10c4db16ad37d1724d (diff)
downloadconnman-9e3b1931585c316b741f4daac44511f856d6ca77.tar.gz
connman-9e3b1931585c316b741f4daac44511f856d6ca77.tar.bz2
connman-9e3b1931585c316b741f4daac44511f856d6ca77.zip
Remove gnutls dependency from connman
gnutls dependency is only required when wispr is enabled. Currently connman is build with flag --disable-wispr so gnutls is not required. This patch removes gnutls dependency from spec file. We'll find alternative for gnutls later and add that together with patches related to captive portal Change-Id: I23491ec67c365b4bc89c6231cc0a581431208f5a Signed-off-by: Saurav Babu <saurav.babu@samsung.com>
Diffstat (limited to 'Makefile.am')
-rwxr-xr-xMakefile.am15
1 files changed, 7 insertions, 8 deletions
diff --git a/Makefile.am b/Makefile.am
index cadd787d..82c13dd8 100755
--- a/Makefile.am
+++ b/Makefile.am
@@ -131,7 +131,6 @@ src_connmand_SOURCES = $(gdhcp_sources) $(gweb_sources) \
src_connmand_LDADD = gdbus/libgdbus-internal.la $(builtin_libadd) \
@GLIB_LIBS@ @DBUS_LIBS@ @XTABLES_LIBS@ @GNUTLS_LIBS@ @LIBSYSTEMD_LIBS@ \
- @TPKP_GNUTLS_LIBS@ \
-lresolv -ldl -lrt
src_connmand_LDFLAGS = -Wl,--export-dynamic -pie \
@@ -178,7 +177,7 @@ vpn_connman_vpnd_SOURCES = $(gdhcp_sources) $(builtin_vpn_sources) \
vpn_connman_vpnd_LDADD = gdbus/libgdbus-internal.la $(builtin_vpn_libadd) \
@GLIB_LIBS@ @DBUS_LIBS@ @XTABLES_LIBS@ @GNUTLS_LIBS@ \
- @TPKP_GNUTLS_LIBS@ @LIBSYSTEMD_LIBS@ \
+ @LIBSYSTEMD_LIBS@ \
-lresolv -ldl
vpn_connman_vpnd_LDFLAGS = -Wl,--export-dynamic \
@@ -224,7 +223,7 @@ endif
endif
AM_CFLAGS = @DBUS_CFLAGS@ @GLIB_CFLAGS@ @XTABLES_CFLAGS@ @LIBSYSTEMD_CFLAGS@\
- @GNUTLS_CFLAGS@ @TPKP_GNUTLS_CFLAGS@ $(builtin_cflags) \
+ @GNUTLS_CFLAGS@ $(builtin_cflags) \
-DCONNMAN_PLUGIN_BUILTIN \
-DSTATEDIR=\""$(statedir)"\" \
-DVPN_STATEDIR=\""$(vpn_statedir)"\" \
@@ -236,13 +235,13 @@ AM_CFLAGS = @DBUS_CFLAGS@ @GLIB_CFLAGS@ @XTABLES_CFLAGS@ @LIBSYSTEMD_CFLAGS@\
-fPIE
if VPN
-AM_CPPFLAGS = @TPKP_GNUTLS_CFLAGS@ -I$(builddir)/include -I$(srcdir)/gdbus
+AM_CPPFLAGS = -I$(builddir)/include -I$(srcdir)/gdbus
else
-AM_CPPFLAGS = @TPKP_GNUTLS_CFLAGS@ -I$(builddir)/include -I$(builddir)/src -I$(srcdir)/gdbus
+AM_CPPFLAGS = -I$(builddir)/include -I$(builddir)/src -I$(srcdir)/gdbus
endif
src_connmand_CFLAGS = @DBUS_CFLAGS@ @GLIB_CFLAGS@ @XTABLES_CFLAGS@ \
- @GNUTLS_CFLAGS@ @TPKP_GNUTLS_CFLAGS@ $(builtin_cflags) \
+ @GNUTLS_CFLAGS@ $(builtin_cflags) \
-DCONNMAN_PLUGIN_BUILTIN \
-DSTATEDIR=\""$(statedir)"\" \
-DPLUGINDIR=\""$(build_plugindir)"\" \
@@ -309,7 +308,7 @@ if WISPR
noinst_PROGRAMS += tools/wispr
tools_wispr_SOURCES = $(gweb_sources) tools/wispr.c
-tools_wispr_LDADD = @GLIB_LIBS@ @GNUTLS_LIBS@ @TPKP_GNUTLS_LIBS@ -lresolv
+tools_wispr_LDADD = @GLIB_LIBS@ @GNUTLS_LIBS@ -lresolv
endif
if TOOLS
@@ -329,7 +328,7 @@ tools_supplicant_test_LDADD = gdbus/libgdbus-internal.la \
@GLIB_LIBS@ @DBUS_LIBS@
tools_web_test_SOURCES = $(gweb_sources) tools/web-test.c
-tools_web_test_LDADD = @GLIB_LIBS@ @GNUTLS_LIBS@ @TPKP_GNUTLS_LIBS@ -lresolv
+tools_web_test_LDADD = @GLIB_LIBS@ @GNUTLS_LIBS@ -lresolv
tools_resolv_test_SOURCES = gweb/gresolv.h gweb/gresolv.c tools/resolv-test.c
tools_resolv_test_LDADD = @GLIB_LIBS@ -lresolv