summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorDaniel Wagner <daniel.wagner@bmw-carit.de>2013-03-12 18:16:37 +0100
committerPatrik Flykt <patrik.flykt@linux.intel.com>2013-03-18 14:31:26 +0200
commit2111d6e8f63a03b6945ab8005ea437c63b2bd6b8 (patch)
tree1b12254edbdade8dcc3d5b2811d6861552da33e3 /Makefile.am
parent4f385e17ccb2f05fa1b472d173ed143447090ce2 (diff)
downloadconnman-2111d6e8f63a03b6945ab8005ea437c63b2bd6b8.tar.gz
connman-2111d6e8f63a03b6945ab8005ea437c63b2bd6b8.tar.bz2
connman-2111d6e8f63a03b6945ab8005ea437c63b2bd6b8.zip
iptables-test: Use iptables implementation from core
With the recent changes to iptables.c and the new API iptables-test.c and iptables.c started to diverge and it is not really possible to keep those two files in sync. Instead we start using the new API. Unfortunatly, we need to partially parse argv and concatinate the rest again together. This is ugly but not much we can do about it.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 87211230..55b0bbac 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -296,7 +296,8 @@ tools_dbus_test_LDADD = @GLIB_LIBS@ @DBUS_LIBS@
tools_polkit_test_LDADD = @DBUS_LIBS@
-tools_iptables_test_LDADD = @GLIB_LIBS@ @XTABLES_LIBS@
+tools_iptables_test_SOURCES = src/log.c src/iptables.c tools/iptables-test.c
+tools_iptables_test_LDADD = @GLIB_LIBS@ @XTABLES_LIBS@ -ldl
tools_private_network_test_LDADD = @GLIB_LIBS@ @DBUS_LIBS@