summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorPatrik Flykt <patrik.flykt@linux.intel.com>2012-11-26 15:40:02 +0200
committerPatrik Flykt <patrik.flykt@linux.intel.com>2012-11-26 16:25:14 +0200
commitaf7bc4b78e399944c8a95c36523148ffb81d8b63 (patch)
treed4356996d72945bd1e8438211eb32a7f651536ab /Makefile.am
parent547d1108612809f5ee4a9bf4b5028055f8a712a1 (diff)
downloadconnman-af7bc4b78e399944c8a95c36523148ffb81d8b63.tar.gz
connman-af7bc4b78e399944c8a95c36523148ffb81d8b63.tar.bz2
connman-af7bc4b78e399944c8a95c36523148ffb81d8b63.zip
build: Fix up distribution dependencies in makefiles
Ensure all files needed at build time are added to the distribution tar file, especially those for VPN. Files in any *_SOURCES variables or ending with *.in are already covered.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am7
1 files changed, 4 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index bd130c3e..d3146f3d 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -207,9 +207,10 @@ vpn_connman_vpnd_CFLAGS = @DBUS_CFLAGS@ @GLIB_CFLAGS@ \
-DCONFIGDIR=\""$(configdir)\"" \
-I$(builddir)/vpn
-EXTRA_DIST += vpn/vpn-dbus.conf vpn/vpn-polkit.conf vpn/net.connman.vpn.service
endif
+EXTRA_DIST += vpn/vpn-dbus.conf vpn/vpn-polkit.conf
+
script_DATA =
script_PROGRAMS =
script_LTLIBRARIES =
@@ -311,10 +312,8 @@ test_scripts = test/get-state test/list-services \
test/set-global-timeservers test/get-global-timeservers \
test/set-nameservers test/set-domains test/set-timeservers
-if VPN
test_scripts += test/vpn-connect test/vpn-disconnect test/vpn-get \
test/monitor-vpn
-endif
if TEST
testdir = $(pkglibdir)/test
@@ -389,6 +388,8 @@ connman-task.pp: vpn/connman-task.te
make -f /usr/share/selinux/devel/Makefile
endif
+EXTRA_DIST += vpn/connman-task.te
+
include/connman/version.h: include/version.h
$(AM_V_at)$(MKDIR_P) include/connman
$(AM_V_GEN)$(LN_S) $(abs_top_builddir)/$< $@