summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorNiraj Kumar Goit <niraj.g@samsung.com>2016-06-14 22:24:37 +0530
committerNiraj Kumar Goit <niraj.g@samsung.com>2016-06-15 01:26:32 +0530
commit535e7f69c650dd1701cdb94152a88e644d079afb (patch)
tree0143a3631860fe7d3c15453b2311312de270bd3d /Makefile.am
parent8bf82d09ca26e4d463314948de7154aac1806d37 (diff)
downloadconnman-535e7f69c650dd1701cdb94152a88e644d079afb.tar.gz
connman-535e7f69c650dd1701cdb94152a88e644d079afb.tar.bz2
connman-535e7f69c650dd1701cdb94152a88e644d079afb.zip
[SPIN] gsupplicant: fix stucking in scanning state when scan failed.
- gsupplicant: fix stucking in scanning state when scan failed. - Apply ASLR option. - Add ""TIZEN_WEARABLE"" check in service file. - change the dhcp client device name. - default internet service: fix not cleared if pdp activation failed. - Change Russia cert build feature. - Update the Connman.service.in file. - Remove connection retry when association fail. Change-Id: I3ac8e49d0a3c229b298296f8e7cbf34845c2c90d Signed-off-by: Niraj Kumar Goit <niraj.g@samsung.com>
Diffstat (limited to 'Makefile.am')
-rwxr-xr-xMakefile.am5
1 files changed, 3 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 5be7625f..f5535da5 100755
--- a/Makefile.am
+++ b/Makefile.am
@@ -115,7 +115,7 @@ src_connmand_LDADD = gdbus/libgdbus-internal.la $(builtin_libadd) \
@TPKP_GNUTLS_LIBS@ \
-lresolv -ldl -lrt
-src_connmand_LDFLAGS = -Wl,--export-dynamic \
+src_connmand_LDFLAGS = -Wl,--export-dynamic -pie \
-Wl,--version-script=$(srcdir)/src/connman.ver
if VPN
@@ -209,7 +209,8 @@ AM_CFLAGS = @DBUS_CFLAGS@ @GLIB_CFLAGS@ @XTABLES_CFLAGS@ \
-DSCRIPTDIR=\""$(build_scriptdir)"\" \
-DSTORAGEDIR=\""$(storagedir)\"" \
-DVPN_STORAGEDIR=\""$(vpn_storagedir)\"" \
- -DCONFIGDIR=\""$(configdir)\""
+ -DCONFIGDIR=\""$(configdir)\"" \
+ -fPIE
if VPN
AM_CPPFLAGS = @TPKP_GNUTLS_CFLAGS@ -I$(builddir)/include -I$(srcdir)/gdbus