summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorMartin Xu <martin.xu@intel.com>2010-11-12 17:52:18 +0100
committerSamuel Ortiz <sameo@linux.intel.com>2010-11-13 23:35:38 +0100
commit7da565d421d475158f016af8ad7850ebd42646fb (patch)
treed1d630bdb897e5f90042b42c8f2ba631eff0c6a7 /Makefile.am
parentb3fb03c5c032d40667a767a301c07ebf4c051d05 (diff)
downloadconnman-7da565d421d475158f016af8ad7850ebd42646fb.tar.gz
connman-7da565d421d475158f016af8ad7850ebd42646fb.tar.bz2
connman-7da565d421d475158f016af8ad7850ebd42646fb.zip
dhcp-server-test: Initial implementation
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am7
1 files changed, 5 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 18a58b63..cba6b9c8 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -128,8 +128,8 @@ endif
if TOOLS
noinst_PROGRAMS += tools/wispr tools/wifi-scan tools/supplicant-test \
- tools/dhcp-test tools/addr-test \
- tools/web-test tools/resolv-test \
+ tools/dhcp-test tools/dhcp-server-test \
+ tools/addr-test tools/web-test tools/resolv-test \
tools/dbus-test tools/polkit-test \
tools/iptables-test tools/tap-test tools/wpad-test \
tools/stats-ringbuffer-dump
@@ -156,6 +156,9 @@ tools_wpad_test_LDADD = @GLIB_LIBS@ -lresolv
tools_dhcp_test_SOURCES = $(gdhcp_sources) tools/dhcp-test.c
tools_dhcp_test_LDADD = @GLIB_LIBS@
+tools_dhcp_server_test_SOURCES = $(gdhcp_sources) tools/dhcp-server-test.c
+tools_dhcp_server_test_LDADD = @GLIB_LIBS@
+
tools_dbus_test_SOURCES = $(gdbus_sources) tools/dbus-test.c
tools_dbus_test_LDADD = @GLIB_LIBS@ @DBUS_LIBS@