summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorMarcel Holtmann <marcel@holtmann.org>2010-01-02 19:19:06 -0800
committerMarcel Holtmann <marcel@holtmann.org>2010-01-02 19:19:06 -0800
commitb4e8b10030d97b1c4a2416b2b998f4f9ba8436e7 (patch)
tree4bdce44f677d4431cbfc4eabea5fc1da757006c6 /Makefile.am
parent8c28004e03f20b4ca78f9a7d2e28ac1d9e4e5619 (diff)
downloadconnman-b4e8b10030d97b1c4a2416b2b998f4f9ba8436e7.tar.gz
connman-b4e8b10030d97b1c4a2416b2b998f4f9ba8436e7.tar.bz2
connman-b4e8b10030d97b1c4a2416b2b998f4f9ba8436e7.zip
Add test program for D-Bus library memory leak checks
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am5
1 files changed, 4 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 92e354b5..f294c254 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -113,7 +113,7 @@ client_cm_LDADD = @DBUS_LIBS@
endif
if TOOLS
-noinst_PROGRAMS += tools/wifi-scan tools/supplicant-test \
+noinst_PROGRAMS += tools/wifi-scan tools/supplicant-test tools/dbus-test \
tools/addr-test tools/tap-test tools/polkit-test
tools_wifi_scan_LDADD = @GLIB_LIBS@ @NETLINK_LIBS@
@@ -123,6 +123,9 @@ tools_supplicant_test_SOURCES = $(gdbus_sources) tools/supplicant-test.c \
tools/supplicant.h tools/supplicant.c
tools_supplicant_test_LDADD = @GLIB_LIBS@ @DBUS_LIBS@
+tools_dbus_test_SOURCES = $(gdbus_sources) tools/dbus-test.c
+tools_dbus_test_LDADD = @GLIB_LIBS@ @DBUS_LIBS@
+
tools_polkit_test_LDADD = @DBUS_LIBS@
endif