summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorSamuel Ortiz <sameo@linux.intel.com>2010-08-17 17:10:46 +0200
committerSamuel Ortiz <sameo@linux.intel.com>2010-08-17 17:11:49 +0200
commitff4679178975cede4a4173bcf03447f1c0058d73 (patch)
treed99d039631a372b50cdc6f797a3dd4e6369511f1 /Makefile.am
parent5f06e7b159df42ceafafe9a7266148f658a91fad (diff)
downloadconnman-ff4679178975cede4a4173bcf03447f1c0058d73.tar.gz
connman-ff4679178975cede4a4173bcf03447f1c0058d73.tar.bz2
connman-ff4679178975cede4a4173bcf03447f1c0058d73.zip
ConnMan backtrace support
Add a generic signal handler in order to dump ConnMan backtrace when crashing. The implementation is based on glibc backtrace() routines and thus can not resolve static function names. A little python wrapper over addr2line fixes that by taking a full backtrace from a complete connman log file.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index ed4689c9..1bf72074 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -179,7 +179,7 @@ test_scripts = test/get-state test/list-profiles test/list-services \
test/monitor-manager test/test-counter test/set-ip-method \
test/set-nameservers test/set-domains test/find-service \
test/get-services test/get-proxy-autoconfig \
- test/enable-tethering test/disable-tethering
+ test/enable-tethering test/disable-tethering test/backtrace
if TEST
testdir = $(pkglibdir)/test