summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorPatrik Flykt <patrik.flykt@linux.intel.com>2013-03-27 13:53:49 +0200
committerPatrik Flykt <patrik.flykt@linux.intel.com>2013-04-04 10:22:13 +0300
commit3ff40ccff44a46e735189b528abd73a3ff7a0511 (patch)
tree18686c3c705fa7e47271f574967d849f2dd3b091 /Makefile.am
parent4f21d25e38219c3b909674327d66c2d6219e99c2 (diff)
downloadconnman-3ff40ccff44a46e735189b528abd73a3ff7a0511.tar.gz
connman-3ff40ccff44a46e735189b528abd73a3ff7a0511.tar.bz2
connman-3ff40ccff44a46e735189b528abd73a3ff7a0511.zip
client: Add input handling
Set up readline command line input handling. Add helper functions to save and redraw the command line when output needs to be printed to the screen.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 21b7070b..5e8eefe8 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -236,7 +236,8 @@ client_connmanctl_SOURCES = $(gdbus_sources) src/connman.h \
client/technology.h client/technology.c \
client/interactive.h client/interactive.c \
client/monitor.h client/monitor.c \
- client/commands.c client/main.c
+ client/commands.h client/commands.c client/main.c \
+ client/input.h client/input.c
client_connmanctl_LDADD = @DBUS_LIBS@ @GLIB_LIBS@ -lreadline -ldl
endif