summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorMarcel Holtmann <marcel@holtmann.org>2010-07-29 16:27:55 -0700
committerMarcel Holtmann <marcel@holtmann.org>2010-07-29 16:27:55 -0700
commit33691ed273a0d36bfd5b7b841018fd4695a6dcab (patch)
tree555e760fd740665f557cbcedb5a2b605699c248c /Makefile.am
parent9c8149957d6cdeba6d8c83200645054852a75b49 (diff)
downloadconnman-33691ed273a0d36bfd5b7b841018fd4695a6dcab.tar.gz
connman-33691ed273a0d36bfd5b7b841018fd4695a6dcab.tar.bz2
connman-33691ed273a0d36bfd5b7b841018fd4695a6dcab.zip
Fix build issue with dhclient-test utility
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am11
1 files changed, 9 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 875da95a..ab979f26 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -124,7 +124,7 @@ if TOOLS
noinst_PROGRAMS += tools/wifi-scan tools/supplicant-test tools/dhcp-test \
tools/addr-test tools/tap-test tools/resolv-test \
tools/dbus-test tools/polkit-test tools/portal-test \
- tools/iptables-test tools/dhclient-test tools/wpad-test
+ tools/iptables-test tools/wpad-test
tools_wifi_scan_LDADD = @GLIB_LIBS@ @NETLINK_LIBS@
@@ -151,8 +151,15 @@ tools_portal_test_LDADD = @GLIB_LIBS@
tools_iptables_test_LDADD = @IPTC_LIBS@ -lip4tc -lxtables
-tools_dhclient_test_SOURCES = $(gdbus_sources) tools/dhclient-test.c
+if DHCLIENT
+noinst_PROGRAMS += tools/dhclient-test
+
+tools_dhclient_test_SOURCES = gdbus/gdbus.h gdbus/mainloop.c gdbus/watch.c \
+ tools/dhclient-test.c
tools_dhclient_test_LDADD = @GLIB_LIBS@ @DBUS_LIBS@
+
+tools_dhclient_test_CFLAGS = $(AM_CFLAGS) -DDHCLIENT=\"@DHCLIENT@\"
+endif
endif
test_scripts = test/get-state test/list-profiles test/list-services \