summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorDaniel Wagner <daniel.wagner@bmw-carit.de>2013-03-12 18:16:32 +0100
committerPatrik Flykt <patrik.flykt@linux.intel.com>2013-03-18 14:31:25 +0200
commit1838dd68416a52ab47b9c7e42f4442c093989174 (patch)
treee06a467b1bfec9fb04ad1cc3aa4cd9ee843fc86e /Makefile.am
parent46ca83850e0083aceec845639f3a2085c6cc6a0a (diff)
downloadconnman-1838dd68416a52ab47b9c7e42f4442c093989174.tar.gz
connman-1838dd68416a52ab47b9c7e42f4442c093989174.tar.bz2
connman-1838dd68416a52ab47b9c7e42f4442c093989174.zip
test-iptables: Move file to tools and rename it to iptables-unit
Unit tests are suppessed to be run during 'make distcheck' but iptables-unit needs to be run with root rights.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am10
1 files changed, 5 insertions, 5 deletions
diff --git a/Makefile.am b/Makefile.am
index 9fc159c4..8b302758 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -267,7 +267,7 @@ noinst_PROGRAMS += tools/supplicant-test \
tools/iptables-test tools/tap-test tools/wpad-test \
tools/stats-tool tools/private-network-test \
unit/test-session unit/test-ippool \
- unit/test-iptables
+ tools/iptables-unit
tools_supplicant_test_SOURCES = $(gdbus_sources) tools/supplicant-test.c \
tools/supplicant-dbus.h tools/supplicant-dbus.c \
@@ -311,10 +311,10 @@ unit_test_ippool_SOURCES = $(gdbus_sources) src/log.c src/dbus.c \
unit_test_ippool_LDADD = @GLIB_LIBS@ @DBUS_LIBS@ -ldl
unit_objects += $(unit_test_ippool_OBJECTS)
-unit_test_iptables_SOURCES = $(gdbus_sources) src/log.c \
- src/iptables.c src/nat.c unit/test-iptables.c
-unit_test_iptables_LDADD = @GLIB_LIBS@ @DBUS_LIBS@ @XTABLES_LIBS@ -ldl
-unit_objects += $(unit_test_iptables_OBJECTS)
+tools_iptables_unit_SOURCES = $(gdbus_sources) src/log.c \
+ src/iptables.c src/nat.c tools/iptables-unit.c
+tools_iptables_unit_LDADD = @GLIB_LIBS@ @DBUS_LIBS@ @XTABLES_LIBS@ -ldl
+
endif
test_scripts = test/get-state test/list-services \